Iomega HD randomly dismounting - drive problem or hub problem?

Discussion in 'Mac Accessories' started by AVR2, Mar 11, 2016.

  1. AVR2, Mar 11, 2016
    Last edited: Mar 11, 2016

    AVR2 macrumors 6502

    Joined:
    Jan 16, 2006
    #1
    I have an Iomega MiniMax external drive with the built-in FW400 and USB2 hubs, which I use as my media drive for Plex. I've had it for about 4 years and I upgraded the HD about 2 years ago.

    Just lately, it's started becoming unreliable. It now takes anything up to 30 seconds after powering it up before it mounts, it never mounts automatically after a reboot (it always used to), and I'm seeing occasional freezes during playback. Sometimes it will continue playing after a random period, sometimes it won't. If it won't, that's generally because it's suddenly dismounted, and I get the "hard drive was disconnected without being ejected" warning.

    Before the random dismounts I was only suspecting that the HD needed replacing, but now I'm wondering if the hub part is faulty. I've always had it connected to my mini via FW, so I experimentally tried doing it with USB2, and that made no difference.

    I don't think I've ever experienced random dismounts as a symptom of a failing external drive before. Does it sound like the hub part could be on its way out? A shame if so, because it's obviously an obsolete unsupported product that I won't be able to get repaired, and I do like the fact that its design complements the mini.
     
  2. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #2
    It sounds far more like a connection issue than a drive issue, pointing to a problem with the USB/FireWre interfaces on the device.

    To confirm, either take the drive out and connect it using another enclosure or a SATA-USB cable or install another drive in the Iomega.
    Also try connecting the Iomega to another machine if there's any chance the ports on the Mac mini are wonky.
     
  3. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    OP:

    Is the drive connected directly to the Mac, or are you using a hub of any kind?
     
  4. AVR2 thread starter macrumors 6502

    Joined:
    Jan 16, 2006
    #4
    As I mentioned in my original post, it's a MiniMax external HD, which has its own built-in FW400 and USB2 hubs (three ports for each).

    And yes, it was a hub issue. I removed the HD from the MiniMax and have it installed in a USB-to-SATA caddy, and it's working just fine. So sadly, that means that the MiniMax enclosure is only fit for the trash; as an unsupported legacy device, Iomega have zero interest and there's no way I'll be able to get it repaired.
     
  5. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    OP:

    Are you by chance using El Capitan?

    If so, you might be interested in this info I archived from the macintouch.com web site:
    =======
    James Katt

    I held off on upgrading my MacBook Pro 15 Retina to OS X 10.11 El Capitan because it is my work computer. I finally was forced to upgrade this past weekend after several app developers decided to only support OS X 10.11 for their apps.

    Generally things worked well except for the USB 3.0 ports and the printer driver to my Lexmark T640 - and these problems drive me nuts.

    In 10.11, an Apple engineer completely rewrote the USB drivers. The new drivers appear to employ the use of ACPI to a much greater extent than the previous drivers. The drivers use ACPI to obtain information about which ports are active. Often, this information is wrong and needs to be updated. But rather than update the information about what ports are active to correct the situation, Apple failed to do so. This is the bug.

    In fact, this bug even prevented Apple's own Macs from working. So another Apple engineer rather than correct the bug, decided to hack OS X by creating a port injector to override the DSDT so that Macs could work. But this solution does not work for external USB 3.0 hubs.

    The limitation that the new USB driver leaves us is that each external USB 3.0 hub needs one controller chip for every 4 USB 3.0 ports. Only a few external USB 3.0 hubs do this - such as the Plugable 7-Port USB 3.0 SuperSpeed Hub with 25W Power Adapter and Two Ports with BC 1.2 Charging Support.

    So as a result of this driver bug, the vast majority of external USB 3.0 hubs with more than 4 ports fail.
     

Share This Page