Iomega minimax 2tb external HDD firewire connectivity issues?

Discussion in 'Mac Basics and Help' started by AJ100, Nov 20, 2011.

  1. AJ100 macrumors newbie

    Joined:
    Nov 20, 2011
    #1
    Hi all. I just bought a iomega minimax 2tb HDD. I have a MacBook with firewire bus with maximum connectivity of up to 400 mb/sec. I connected my MacBook to Minimax with the firewire 800-400 cable provided in the box but could not see Minimax on my desktop / mounted.
    When I connected Minimax only with the USB cable provided it connects.
    Tried troubleshooting on the iomega website but no use.

    Need some help on this.
    Regards
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    Firewire 400-800 cables are common and usually no problem. I have an Iomega firewire drive and it came with a variety of firewire cables and had no problem with them, either using firewire 400 or 800. You could have a bad firewire cable or a bad firewire port on the Mac.
     
  3. AJ100 thread starter macrumors newbie

    Joined:
    Nov 20, 2011
    #3
    Iomega minimax 2tb external HDD firewire connectivity issues?

    Thanks Old-Wiz,
    Thanks for your advice. The hard disc and the cable were brand new and they were working good. Basically my Macbook is 2006 version and needed some firmware update. After updating, there is good firewire connection between the two.
    Many thanks for your advice again.

    Regards
     
  4. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #4
    Glad you got it working! I love firewire - it's so much faster than USB.
     

Share This Page