iOS 10.1.1 (and 10.1) keyboard lag

Discussion in 'iOS 10' started by ycoidi2000, Nov 5, 2016.

  1. ycoidi2000 macrumors member

    Joined:
    Jul 27, 2008
    #1
    I can't be the only one with this (or I just can't find a thread)...

    I am having extreme and occasional keyboard lags on my iOS 10.1 and 10.1.1 devices (iPhone 7, iPad mini 4, and iPad 9.7 Pro). When I type on the keyboard, occasionally I'll get a 5-10 second freeze before the text shows up. (It'll happen in the middle of what I'm typing.) The fact that it is happening on all of my devices (and my wife's iPhone 7 and iPad mini 2) seems to tell me it's systemic to the operating system (it didn't happen in the initial iOS 10 release).

    I have found that switching to other keyboard (like Gboard) brings me back to normal operation, but I want to use the Apple keyboard.

    Any thoughts?

    Thanks!
     
  2. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #2
    Restore your phone as new? Last time I had keyboard lag was my iPad 2 on iOS 8/9. My Air 2 and 7Plus have not had a single bit of keyboard lag since getting them and on all versions of iOS, including 10.1.1.
     
  3. Marshall73 macrumors 6502a

    Marshall73

    Joined:
    Apr 20, 2015
    #3
    Would try a reset all settings before completely wiping it.
     
  4. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #4
    Thats useful for battery drain and what not. But I don't think resetting all settings will make a single change with the keyboard lagging. That seems to be a corruption issue with the install of iOS.
     
  5. greatness macrumors member

    Joined:
    Jun 15, 2014
    #5
    there is a definite lag on the iPhone 6. unfortunate to hear that the 7 is affected as well. I suspect iOS taking up additional resources, and apps not being optimized for it.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Perhaps some might be experiencing something like that for some reason, but it definitely doesn't apply to all or most or even likely that many such phones.
     
  7. ycoidi2000 thread starter macrumors member

    Joined:
    Jul 27, 2008
    #7
    Yeah...something goofy must be going on. I tried wiping settings. The lag continued. I then made the decision to wipe the entire phone and start over. With only a couple of apps added, the lag is still there (and it's significant).

    I put Gboard back on and it works fine. I'm really confused. I don't really see the point of taking it to the Genius Bar, so I might be stuck with it (my wife's iPhone 7 and my daughter's iPhone 7 don't have this problem... strange...)
     
  8. lakaiordie macrumors 65816

    Joined:
    Jun 17, 2008
    #8

    How did you do the wipe exactly?
     

Share This Page