iOS 10.3.3 performance

chillip

macrumors 65816
Original poster
Mar 16, 2013
1,271
624
There doesn't seem to be a thread on this. How are you finding the performance etc. My iPhone 7 feels snappier with slightly faster animations.
 

pandi.ruvina

macrumors regular
Mar 17, 2017
148
42
Probably only on iPhone 7, anyone on older devices like iPhone 5S or other devices?! I'm currently running on iOS 11 beta public 2 on iPhone 5S and I really like it!
 
  • Like
Reactions: robotica

one more

macrumors 65816
Aug 6, 2015
1,455
1,171
Earth
10.3.3 works just fine for us on iPad Air 2, iPhone SE, iPhone 6 and iPhone 7. Faster transitions and less overall lag.
 
  • Like
Reactions: m0jdd

iphonefreak450

macrumors regular
Dec 14, 2014
247
24
Its horrible...internet very slow than before. I am on an iPhone SE. I will reboot my router to see if that helps but never had this issue on 10.3.2 until now after this update.
 

Act3

macrumors 68000
Sep 26, 2014
1,913
2,224
USA
10.3.3 works great and very smooth, lag free on both my air 2 and 6s, both seem as good if not better than the day I got them on as far as performance goes, which has me worried with iOS 11 coming out.
 

Wide opeN

macrumors 68000
Aug 27, 2010
1,726
958
Georgia
It's buttery smooth, safari seems to have zero lag.

Very nice. Along with my Apple watch and SwiftKey update it's like brand new devices.

I have iPhone 7
 
  • Like
Reactions: atlchamp

Mlrollin91

macrumors G5
Nov 20, 2008
13,528
9,078
Ventura County
Things seem to be okay now on both of my devices after having to reset settings on both. For whatever reason, both devices did not like going from B6 -> Final. They were lagging really bad and getting a lot of stock app crashes.
 

prk60091

macrumors member
Nov 13, 2011
72
16
on my ip6 very smooth and battery is aok
after 7 hours of moderate use (surfing/email/msging) down to 68% (ie used 32%) which is pretty good for my typical usage.
 

mitty

macrumors regular
May 21, 2010
154
98
Melbourne
Major Battery issues with 10.3.3. I'm on a 6S that was one year old yesterday. Battery had been fine until I updated. I was having weird issues yesterday after I updated, but this morning I got up at 6:45 and by 7:45 the phone had dropped to 75%, so 25% drop in an hour. I've been in contact with Apple Support via Twitter and they've confirmed it's a software issue, not a Hardware one.
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,528
9,078
Ventura County
Major Battery issues with 10.3.3. I'm on a 6S that was one year old yesterday. Battery had been fine until I updated. I was having weird issues yesterday after I updated, but this morning I got up at 6:45 and by 7:45 the phone had dropped to 75%, so 25% drop in an hour. I've been in contact with Apple Support via Twitter and they've confirmed it's a software issue, not a Hardware one.
Sounds like a one off issue. Try resetting all settings. I highly doubt Apple Support is just going to openly confirm its an issue after 1 day since it came out.
 
  • Like
Reactions: RickFF and robotica

mitty

macrumors regular
May 21, 2010
154
98
Melbourne
Sounds like a one off issue. Try resetting all settings. I highly doubt Apple Support is just going to openly confirm its an issue after 1 day since it came out.
I'll try that. But my partner and a few people at work are having the same issue, so it's certainly not isolated to me.
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,528
9,078
Ventura County
I'll try that. But my partner and a few people at work are having the same issue, so it's certainly not isolated to me.
Weird, because I have noticed an uptick in battery life since updating to 10.3.3 from 10.3.2. A few others I know have noticed the same thing. There are so many variables when it comes to battery life. Possible that your work is having a cellular issue in the area? Because that would definitely explain it.
 

Act3

macrumors 68000
Sep 26, 2014
1,913
2,224
USA
Weird, because I have noticed an uptick in battery life since updating to 10.3.3 from 10.3.2. A few others I know have noticed the same thing. There are so many variables when it comes to battery life. Possible that your work is having a cellular issue in the area? Because that would definitely explain it.
I've noticed my 6s having better battery today with my normal usage
 

mitty

macrumors regular
May 21, 2010
154
98
Melbourne
Weird, because I have noticed an uptick in battery life since updating to 10.3.3 from 10.3.2. A few others I know have noticed the same thing. There are so many variables when it comes to battery life. Possible that your work is having a cellular issue in the area? Because that would definitely explain it.
I updated yesterday morning about 6:30AM (Melbourne time). I noticed a bit of battery weirdness going to work but put my phone on charge throughout the day. Then I went somewhere that involved taking a bunch of photos though only for about half an hour. In that time my battery drained substantially. Then I went home and put my phone on charge. This morning I got up and as I said it dropped 25% in an hour, and I wasn't even using my phone in that time. Checking battery settings it said camera had used 20% of my battery in the last 24 hours.

Yes I agree there are a lot of variables, but i was having no issues and then i updated to 10.3.3 and immediately started having issues. That can't be a coincidence.
 

iamchris1990yal

macrumors newbie
Nov 12, 2012
14
3
I updated my iPhone 7 to iOS 10.3.3 this morning and my battery is draining super fast and when I plug it in to charge it will not go up at all. It just stays static. My phone was working perfectly fine 2 hours ago and now its overheating and dying rapidly. I have no idea what to do! Help? I have already restarted and hard-reset multiple times!
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,528
9,078
Ventura County
I updated my iPhone 7 to iOS 10.3.3 this morning and my battery is draining super fast and when I plug it in to charge it will not go up at all. It just stays static. My phone was working perfectly fine 2 hours ago and now its overheating and dying rapidly. I have no idea what to do! Help? I have already restarted and hard-reset multiple times!
It's probaby indexing. Every time you restart the device or hard restart. It has to start indexing again.
 
  • Like
Reactions: RickFF

Mlrollin91

macrumors G5
Nov 20, 2008
13,528
9,078
Ventura County
Update: I did a reset all settings and this although painful seems to have fixed the problem. Thanks Mlrollin91 for the suggestion.
Yeah it's definitely a pain had to do it for two devices yesterday for massive crashing/lagging issues. But hopefully it works for you.
 

theNatest

macrumors member
Jan 14, 2016
77
61
Twin Cities
No big change on my devices.

This update is moving up in the line to be the next group to board the roller coaster! Let's go!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.