iOS 11 Camera Issue

Discussion in 'iOS 11' started by Maclver, Sep 12, 2017.

  1. Maclver macrumors 68020

    Maclver

    Joined:
    Nov 23, 2008
    Location:
    36°07′53″N 95°56′14″W
    #1
    has anyone experienced the camera app only showing a black screen. It does it on the video camera too. But the weird thing is it works on Snapchat! I’m on iPhone 7 Plus using the GM build and it did this on beta 10.

    Anyone?!


    Thanks!
     

    Attached Files:

  2. Maclver thread starter macrumors 68020

    Maclver

    Joined:
    Nov 23, 2008
    Location:
    36°07′53″N 95°56′14″W
  3. Sharkoneau macrumors 6502a

    Sharkoneau

    Joined:
    Jan 13, 2017
    Location:
    Michigan
    #3
    Did you do a reboot or hard reset? This fixed it for someone else having the same issue.
     
  4. Maclver thread starter macrumors 68020

    Maclver

    Joined:
    Nov 23, 2008
    Location:
    36°07′53″N 95°56′14″W
    #4
    Yes :(
     
  5. Sharkoneau macrumors 6502a

    Sharkoneau

    Joined:
    Jan 13, 2017
    Location:
    Michigan
    #5
    Does it show a black screen for all camera modes, if you can even access them?
     
  6. Maclver thread starter macrumors 68020

    Maclver

    Joined:
    Nov 23, 2008
    Location:
    36°07′53″N 95°56′14″W
    #6

    Time Lapse works, Slo-mo works, Video black screen, Photo black screen, Portrait black screen, Square black screen, Pano works.... It's so weird.
     
  7. Maclver thread starter macrumors 68020

    Maclver

    Joined:
    Nov 23, 2008
    Location:
    36°07′53″N 95°56′14″W
    #7
    I just did a clean install, set up as new phone to iOS 11 GM and same issues. Anyone experienced this?
     
  8. Enjoylife1788 macrumors 6502a

    Joined:
    Aug 22, 2011
    #8
    I am using the iPhone 7 and I am not having an issue. Also it should be fine after restore, which is not the case. You have a hardware issue. Get it replaced.
     
  9. Maclver thread starter macrumors 68020

    Maclver

    Joined:
    Nov 23, 2008
    Location:
    36°07′53″N 95°56′14″W
    #9

    But what’s weird is it works in snap chat
     
  10. Enjoylife1788 macrumors 6502a

    Joined:
    Aug 22, 2011
    #10
    I agree that’s weird. Did you try restoring the phone as new? Not using the backup. Also try getting back to iOS 10.3.3 just to check if it works on iOS 10. That way you could be sure.
     
  11. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #11
    I used to experience it when I was first on iOS 10, but the 10.* updates eventually took care of it.
    --- Post Merged, Sep 16, 2017 ---
    I’ve never experienced it with my iPhone 7 on iOS 11 PB.
     
  12. Maclver thread starter macrumors 68020

    Maclver

    Joined:
    Nov 23, 2008
    Location:
    36°07′53″N 95°56′14″W
    #12
    Restoring now to 10.3.3 to see what that does!
     
  13. zorinlynx macrumors 603

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #13
    I just had this problem. Locking the screen, waiting a few seconds and trying again fixed it.

    However, this bug is a bit disconcerting as it could result in my missing an important photo! Argh. iOS 11 seems like more of a ****-show every day. I think it's time to revert and stay on 10 for the forseeable future.
     
  14. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #14
    Perhaps a bit dramatic.

    iOS 11 is still in Beta. This issue persisted in iOS 10 for months.
     
  15. zorinlynx macrumors 603

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #15
    The GM is a bit late in the beta process to have a serious bug like this.

    At this point we should be dealing with minor cosmetic issues, not bugs that directly break functionality.
     
  16. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #16
    I don’t disagree with you at all on that, but my point still stands.
     
  17. Maclver thread starter macrumors 68020

    Maclver

    Joined:
    Nov 23, 2008
    Location:
    36°07′53″N 95°56′14″W
    #17
    Update: restored to 10.3.3 and had the same problem. So I went to the apple store and they ran diagnostics on it and turns out there was an issue with the camera. So 2 hours later camera replaced and all is good!
     
  18. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #18
    Glad to know it wasn't iOS 11, then!
     
  19. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #19
    Thanks for checking back in!
     
  20. Enjoylife1788 macrumors 6502a

    Joined:
    Aug 22, 2011
    #20
    Pretty weird why it worked with Snapchat. Sometimes hardware issues work in a weird manner.
     

Share This Page

19 September 12, 2017