iOS 11 on iPad: Can't update any apps

Discussion in 'iOS 11' started by GFLPraxis, Jun 22, 2017.

  1. GFLPraxis macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #1
    Hi everyone,

    I installed the iOS 11 beta yesterday, and installation completed...approximately ten minutes before the iOS 11 Beta 2 went live, so I installed that too.

    Unfortunately, since installing iOS 11 (beta), I cannot update any apps. The app store shows me a number of updates available, but when I tap the update button from the list, the "update" gets replaced with a spinning wheel for a moment (normal), then changes back to "update" instead of starting the download.

    I tried updating multiple apps and I rebooted the iPad. No change.


    Finally, I hit "Update all". All of the "update" buttons in the update tab on the app store became spinning wheels, and have remained that way ever since.

    Image-1.jpg


    On the home screen, all of the apps are now darkened/greyed out and say "Waiting" as if they are pending update. But, they never do anything. I can't launch them through the icon, but I can launch them through the task switcher.

    Image-1 (2).jpg

    Any suggestions? Not sure how else to troubleshoot this.

    (Also: anyone else suffering from extremely laggy animations that make it even hard to utilize some of the multitasking function? I'm chalking it up to unoptimized beta for now.)
     
  2. GFLPraxis thread starter macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #2
    Still show waiting on all apps. Also, my Files app doesn't have a Dropbox option; I'm guessing because I need to update Dropbox?
     
  3. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #3
    Have you tried restarting your iPad? Also are they all 64 bit?
     
  4. GFLPraxis thread starter macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #4
    Yes and yes. I'm talking about mainstream apps like Dropbox, Google Maps, Twitter, etc.

    I tried logging out of my iTunes account for the app store, and now I'm in a weird state of being signed on and off simultaneously.

    In the App Store app, I see my icon in the top right, and when I press it, I get the Account page and see my name and account. If I touch my name, I get a New Account setup screen instead of my profile.


    If I go to Settings > iTunes & App Store, it shows me as not signed in. If I hit Sign In, I get a prompt for username and password. If I enter an incorrect password, it errors. If I enter the correct password, the prompt disappears as if it is accepted, but it remains showing me as logged out (button still says "Sign In").

    I have restarted a few times since.
     
  5. lsutigerfan1976 macrumors 68000

    Joined:
    Sep 14, 2012
    #5
    That’s odd, cause mine works fine. I’m using the 10.5 iPad.
     
  6. lmcrael macrumors member

    Joined:
    Sep 22, 2014
    #6
    Same here
     

Share This Page