iPhone iOS 13 CarPlay cuts out

jimmysalg

macrumors member
Original poster
Sep 30, 2007
85
21
Miami
I have an iPhone 11 Pro and im currently running 13.1. I have a 2019 Mini Cooper with wireless CarPlay. Ever sense I got the iPhone 11 it keeps cutting out when playing music, also does it when using SIRI etc. Tried unpairing, turning bluetooth on/off on both the car and the device nothing helps. Any others having issues?
 

AndrewS

macrumors regular
Jul 16, 2002
113
24
Bourbon Country
Had an issue with iOS 12 in a 2019 bmw. Turning airplane mode on then off usually fixed it. You shouldn’t have to re-pair.

I finally took my car in for a recall item and had them update Idrive and now I have no issues.

Some of the issue may be CarPlay but I think a lot is the way the car handles Bluetooth and wifi for wireless CarPlay.

I’d see if you have an update for your car. I think BMW May have just worked this out in June/July.
 

jimmysalg

macrumors member
Original poster
Sep 30, 2007
85
21
Miami
yea I had no issues with 12. I have friends at the dealer and so far I've been the only one with an issue. Thanks for the heads up.
 
  • Like
Reactions: patb23

jimmysalg

macrumors member
Original poster
Sep 30, 2007
85
21
Miami
Update: Paired my wife's phone (same as mine 11pro ios13.1) and had the same issue. The cutting out is not just the streaming music but even the map display refresh seems to be cutting out.
 

BeauGiles

macrumors member
Nov 23, 2008
63
18
Sydney, Australia
Same deal here with my 2017 Subaru Impreza :(

Thought it was 13.1b4 originally when I put it on my iPhone 11 Pro, but still happens on the 13.1 final.

My spare iPhone 7 works fine on 12.4, and my iPhone XS ran fine on iOS 13.1b4

So it seems to be an issue limited to the iPhone 11 series - hoping it's sorted in iOS 13.2.....
 
  • Like
Reactions: jimmysalg

deuxani

macrumors 6502a
Sep 2, 2010
535
484
Aah, so others are having issues too with their 11 Pros and CarPlay. I also have a weird thing with my BMW's wireless CarPlay. With my iPhone X CarPlay would always automatically connect and start when I would unlock my car. However with the 11 Pro CarPlay doesn't start. I see that it's connected to the CarPlay's Wi-Fi and Bluetooth, but it won't start. When I disconnect Bluetooth on my 11 Pro and then reconnect again, CarPlay almost immediately starts and all is fine. So I'm not having sound issues, just connection issues.

With my old X and my wife's 7 Plus it works flawlessly, but with my 11 Pro it doesn't. All devices are on iOS 13.1, so it seems specific to the 11 Pro for me.
 
  • Like
Reactions: jimmysalg

jbachandouris

macrumors 601
Aug 18, 2009
4,560
1,446
Upstate NY
I have a 2018 Malibu and an iPhone Pro Max. Also having CarPlay issues. Sometimes it works, sometimes not. Thought 13.1 would help. It didn't.

I also had to change cables as my aftermarket isn't even recognized by my new phone.

Tried reseting network settings. Only tried to connect once today so far and it worked, but for how long...
 
  • Like
Reactions: jimmysalg

patb23

macrumors newbie
Feb 28, 2009
9
2
I have a 2017 corvette and just updated my iphone X to 13.1. this morning on my way to work my phone would not connect to the car through carplay. this sometimes happens and i just unplug-plug back the cable and its fine. but today that didnt work. this was working fine yesterday before the update. anybody else having similar issues
 

jbachandouris

macrumors 601
Aug 18, 2009
4,560
1,446
Upstate NY
I have a 2017 corvette and just updated my iphone X to 13.1. this morning on my way to work my phone would not connect to the car through carplay. this sometimes happens and i just unplug-plug back the cable and its fine. but today that didnt work. this was working fine yesterday before the update. anybody else having similar issues
Exactly the same. Sometimes it connects, sometimes not. The unplug/replug trick sometimes works. As for bluetooth, if I push on the screen and ask it to connect, it will connect to bluetooth for phone calls at least.
 

patb23

macrumors newbie
Feb 28, 2009
9
2
Exactly the same. Sometimes it connects, sometimes not. The unplug/replug trick sometimes works. As for bluetooth, if I push on the screen and ask it to connect, it will connect to bluetooth for phone calls at least.
what car are you using. I've never tried bluetooth as I dont think it will work with my car. I will try to play with it more after work today. this was working fine before the update though.
 

jimmysalg

macrumors member
Original poster
Sep 30, 2007
85
21
Miami
***ALL*** Might be helpful to specify if you are using wireless CarPlay or wired CarPlay. They work a little different. My issues are with the wireless CarPlay on a 2019 Mini Cooper. Needless to say, it seems iOS13 has some CarPlay bugs
 

deuxani

macrumors 6502a
Sep 2, 2010
535
484
After 13.1.1 everything is fine for me again. Wireless CarPlay starts automatically and music and navigation work without interruption or issues.
 

jimmysalg

macrumors member
Original poster
Sep 30, 2007
85
21
Miami
I seem to have isolated the issue to WiFi interference. Yesterday I went on the turnpike big open area away from houses and the issue went away, as soon as we got off the highway into a populated area issue came right back.
 

mwunderapple1

macrumors newbie
Oct 2, 2019
1
1
Atlanta, GA
My issue is similar: 2018 Honda Civic - iPhone 11 Pro Max - ios13.1.2 beta - Wired CarPlay actually works most of the time but has repeatedly (4 times) just stopped working mid-drive (of my hour+ commute) phone shows charging but no CarPlay or recognition by the car that it is plugged in. The only way I can get it to work is to turn the car off - remove the car from CarPlay - and restart car plug in phone and re-allow CarPlay never did this on my XS Max with any ios13 beta. The phone is the only difference that I can tell.
 
  • Like
Reactions: jimmysalg

jimmysalg

macrumors member
Original poster
Sep 30, 2007
85
21
Miami
I have confirmation that a 2nd Mini Cooper (friend of mine) is having the same issue as mine. Hopefully apple will address this soon.
 
  • Like
Reactions: TheChesterCat

Buran

macrumors 6502
Oct 22, 2007
370
215
13.1.2, Bluetooth works on a 2017 Honda CR-V but the phone book refuses to sync and attempting to answer calls with the steering wheel controls yields "phone not available", at least once. Weird.

Worked fine (and even synced contact pictures) with iOS 12.