iOS 4.1 breaks iPod feature over USB?

Discussion in 'iPhone' started by chromey, Sep 9, 2010.

  1. chromey macrumors member

    Joined:
    Aug 19, 2009
    #1
    I upgraded to iOS 4 on my iPhone 4 last night and everything went well. This morning, I plugged my iPhone into my car stereo using the USB port (something I do on a daily basis) to listen to music on the way to work. In about 5 seconds, I noticed that the music kept cutting out. I unplugged the USB and plugged it back in thinking maybe there was a connection issue. I got the same result - the music kept cutting out. When I listen to the iPod through the speakers on the iPhone, it was working fine. Has anyone else run into this issue?
     
  2. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #2
    Actually, i got that exact same problem with iOS 4.0x

    The update to 4.1 fixed my problems completely and thankfully.

    Try this. Either reboot your iPhone/iPod Touch, or go into the multitask and close each and every app listed. Once they're all closed, go into your iPod app and start some music. Then plug in your iPhone via usb. It should start playing over your car stereo.
     
  3. smuffy macrumors newbie

    Joined:
    Jul 22, 2008
    #3
    Had same problem with one of the other 4.0.x updates...hard reset "fixed" the issue.
     
  4. chromey thread starter macrumors member

    Joined:
    Aug 19, 2009
    #4
    Awesome, I will try that this afternoon. Thanks for the help.
     
  5. chromey thread starter macrumors member

    Joined:
    Aug 19, 2009
    #5
    Tried both of these things out and still no joy. I may try wiping and doing a clean restore tonight and try again.
     
  6. jbro1999 macrumors regular

    Joined:
    Nov 24, 2009
    #6
    I've always had this problem. Only way I could get around it is using bluetooth.
     
  7. ozzyman500 macrumors 65816

    Joined:
    Feb 4, 2009
    #7
    Is this a new bug or just me? I noticed Genius Mixes don't work anymore on the iPod.
     
  8. smuffy macrumors newbie

    Joined:
    Jul 22, 2008
    #8
    Did you try a hard reset? Where you hold both the home button and the power buttons down until it resets?
     
  9. chromey thread starter macrumors member

    Joined:
    Aug 19, 2009
    #9
    I actually didn't the first time, but I did after I read this. It made the sound drop less frequently, but it still drops out every 25-30 seconds. It's strange because it shows on my stereo that it is still playing (e.g. goes from 11 seconds to 12 to 13 without skipping) but no sound is coming out. The sound will drop for about 2-3 seconds (sometimes longer) and then magically pick back up where it is in the song. So, I lose 2 or 3 seconds of the song each time it does this. Apparently it's doing it over bluetooth as well (a LOT less often, maybe once per song) and seems to be negatively affected if I'm running Maps. When I run Maps, the songs play in slow motion. I've tried closing everything except the iPod app and it still does this. It's driving me crazy.
     

Share This Page