iOS 4.2.1 broke my 3g data connectivity.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sgar, Nov 27, 2010.

  1. sgar macrumors newbie

    Joined:
    Aug 19, 2008
    #1
    Hi there, has anyone else noticed 3g data connection being intermittent since 4.2.1? It has happened to me (I have an iPhone 4) and few others @ the Apple support forum. I tried reset network setting ect, but it doesnt help.
    3g data is so bad for me, that I have been forced to disable it and just use Edge atm.
    I am just surprided that this issue hasnt been reported yet, altrough I am sure there is quite few of us with this problem.
     
  2. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #2
    Hm. No problems here.

    Try a hard reset: hold down the home button and sleep button, holding 'em through the slide-to-power-off screen until the screen just goes dark.

    If that doesn't work, maybe visit a local Apple Store for a session at the Genius Bar. Your iPhone 4 is under warranty and they might choose to swap it out.
     
  3. tonydsam macrumors newbie

    Joined:
    Jul 23, 2010
    #3
    I have noticed this as well. I am in the uk but i thought it just may have been problems with my network carrier.
     
  4. sgar thread starter macrumors newbie

    Joined:
    Aug 19, 2008
    #4
    Nope, it has nothing to do with your network carrier.
     
  5. Peterg2 macrumors 6502a

    Joined:
    Jan 28, 2008
    Location:
    Montreal, Canada
    #5
    As I have detailed in this thread:

    http://discussions.apple.com/thread.jspa?threadID=2662084&tstart=0

    My iPhone 4 has performed flawlessly since purchasing it almost 4 months ago, through 4.0.4.0.1 etc etc until 4.2.1 With the latter firmware I am finding sporadic 3G connectivity. When using an internet utilising app, say the integrated App Store app ("Updates"), or others like speedtest.net 8 out of 10 times or 9 out of 10 times it will be fine but in those 1-2 cases out of 10 it will take an inordinate amount of time and then kick out a network problem message from the app.

    This is NOT a matter of my carrier having spotty 3G data connectivity (although Rogers have had it) nor is it a case of the particular celltower being at the time congested (I have duplicated this at 3:30 am and showing 3-5 bars). I know this is not the case as I am still able to switch back to 4.1 as I have on my hard drive the 4.1 GM which I happened to download a few days before the release of 4.1. The 4.1 GM is identical to the release version.

    Anyhow, with (using Windows) shift + restore I have shifted back and forth between 4.1 and 4.2.1 about a dozen times. Not once have I had these problems with 4.1 as I am having with 4.2.1

    I have done everything with 4.2.1. I have reset network settings, reset all settings, restored the software, restored as a new phone not using any backups whatsoever, Done 2 DFU restores (via slightly different methods) and always the same result. I have sporadic 3G network issues which I *never* had before which could not be put at the door of Rogers.

    Clearly this is not a widespread problem - definitely not as widespread as the Wifi issue in iPad and iPhone apple forums. Nevertheless, a lot more people than those reporting it on the apple forums have this problem without knowing it. They simply are not noticing the issues and probably blaming their carrier. A good example is my neighbour who lives in the same apartment building as I do and who has an iPhone 4 also with Rogers and has updated to 4.2.1. When I saw him in the lobby I asked him if he had any issues with 4.2.1 and he said no. I asked him if I could try out his phone and he gave it to me. I was able to duplicate this issue in a few minutes on his phone.
     

Share This Page