iOS 4.2.1 Wifi Issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Acronym, Dec 6, 2010.

  1. Acronym macrumors 68000

    Joined:
    Apr 26, 2008
    #1
    I am sure I am not the only one having an issue with this, I upgraded my iPhone 3GS to 4.2.1 factory fresh install and it will connect to my router but will not let me load anything from then on. It says I;m connected but in reality I have no connectivity.

    anyone else experience this? I have searched the forums and Couldn't seem to find something related (maybe I'm blind) to this.

    I'd like to get this sorted and would also like to avoid re-installing my iOS again, thanks for your speedy replies.
     
  2. Acronym thread starter macrumors 68000

    Joined:
    Apr 26, 2008
    #2
    Really? 56 people and no one can provide any details? I have searched on Google and found some information but, it does not seem to work so I am curious as to whether this is a problem I'm experiencing or others are as well.
     
  3. leog macrumors newbie

    Joined:
    Mar 10, 2008
    #3
    I have always had issues with my iPhone4 and wifi at my place...it will be connected for a while, but once it wakes up from a period of inactivity, it will not be able to load any data, even though it shows a full wifi signal. I think Apple's 802.11 software is pretty poor; they probably only test with their own Airport equipment.
     
  4. VictorNT macrumors member

    Joined:
    Jul 18, 2007
    Location:
    New York City
    #4
  5. Acronym thread starter macrumors 68000

    Joined:
    Apr 26, 2008
    #5
    My iPhone isn't even obtaining an IP adress, when I log into the web access for my routers settings it doesn't show up in the list.

    I took a look at the weboage you linked me to and so far haven't been able to do much, renewing my lease does nothing as per my problem stated above.
     
  6. djsmock macrumors newbie

    Joined:
    Dec 7, 2010
    #6
    3 iPhones - WiFi is different on each

    There are 3 iPhones in the house. One sees the home wireless and automatically connects. One sees the home wireless and asks for a password each time. One will not even see the home wireless. Router firmware is up to date. Network has been reset on the 2 phones. Nothing works. Apparently, this is a very common problem.
     
  7. Acronym, Dec 7, 2010
    Last edited: Dec 7, 2010

    Acronym thread starter macrumors 68000

    Joined:
    Apr 26, 2008
    #7
    I ran my phone through DFU mode and still no avail, and the website provided doesn't really provide any more information then what I've already seen. I am limited to what I can do exactly on the router, as it is not mine, I do however have access to the admin settings.

    any more information on the matter would be greatly appreciated.

    ***EDIT*** the router isn't even seeing the iphone as connected, yet my iPhone has an IP address and a subnet mask, renewing the lease does nothing, resetting the network settings from my phone does nothing, rebooting the router does nothing, DFU mode and setting up as a new phone does nothing.

    I have searched all over google and have only found answers that don't solve my question.
     
  8. gslrider macrumors 6502

    gslrider

    Joined:
    Nov 4, 2005
    #8
    I've read that the iPhone's advertised 802.11N, isn't really running at N, more like 802.11B. So you may want to check your wireless router settings to accomodate B, G, and N.
     
  9. Acronym thread starter macrumors 68000

    Joined:
    Apr 26, 2008
    #9
    I checked my wireless router settings and it's set to broadcast on all frequencies N,G,B. So that theory is out as well. Apple had better come out with an update soon, I didn't upgrade so that I could lose wifi abilities.
     
  10. Acronym thread starter macrumors 68000

    Joined:
    Apr 26, 2008
    #10
    Ok so dummy of the year award goes to me, my girlfriend while playing with my phone entered her wifi password when one of those onscreen printings came up, it connected.

    Apparently I was entering the password wrong, however it still doesn't explain why the router was accepting my incorrect password to begin with.

    Either way problem solved and I'm eating my own foot because of it haha
     
  11. gslrider macrumors 6502

    gslrider

    Joined:
    Nov 4, 2005
    #11
    Glad it worked out for you. But that is weird that it showed you had wi-fi connection but couldn't connect. Perhaps, you were connected to another wireless router with poor connection? How many bars were you getting before you fixed the issue?
     
  12. Acronym thread starter macrumors 68000

    Joined:
    Apr 26, 2008
    #12
    They have satelite Internet, because we live more in the country then the city, so I would not be able to connect to any other network. If I disabled my 3G connection I'd "apparently" have full bars of service.
     

Share This Page