iOS 4.2.1 with bb 5.13.04 on iPhone 3G

Discussion in 'Jailbreaks and iOS Hacks' started by keerti, Dec 25, 2010.

  1. keerti, Dec 25, 2010
    Last edited: Dec 25, 2010

    keerti macrumors newbie

    Joined:
    Nov 7, 2010
    #1
    I am currently on iOS 4.1 on my iPhone 3G .
    the bb version is 5.13.04.
    I need to upgrade to ios4.2 but I will do so only if it is possible to retain the same baseband without upgrading to bb 6.15.04.

    I have searched this forum and others alike, but Boone seems to have addressed this particular issue. can someone help me?



    I have an iPhone 3G , unlocked , iOS 4.1, bb 5.13.04,
    windows 7.
    I do rely on an unlock:)
     
  2. Junkboxy macrumors member

    Joined:
    Sep 17, 2008
    #2
    1. You can download a custom 4.2.1 IPSW from a friendly hacker who has used Pwnage Tool on mac to build it, and then use that custom ipsw with redsn0w (verify this, I think I've seen it talked about in here, but I consider this risky)

    2. You can get a Mac, use PwnageTool_4.1.3_Unlock_Edition. Hope-and-pray that it works good rolling a 4.2.1. I myself almost did this, but then thought it best to be safe. We as 3G owners may be in the clear - (there does currently exist an iClarified tutorial on this one) - but I don't like using a lower-version Pwnage Tool to pwn a higher-version firmware.

    3. You can get a Mac, wait for Pwnage Tool 4.2.1.

    The more inexperienced you are, the more I would point you to option 3. It's best that YOU be the one ticking off all the boxes when its YOUR phone that your rely on unlocked.
     
  3. keerti thread starter macrumors newbie

    Joined:
    Nov 7, 2010
    #3
    i was thinking that if i use redsnow and leave the "install ipad baseband " unchecked, then it might be left with 5.13.04 and hence i can then use ultrasn0w to unlock it .

    would that work ?
     
  4. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #4
    Yes. You don't need to upgrade your baseband since you have one that can be unlocked already.
     
  5. Junkboxy macrumors member

    Joined:
    Sep 17, 2008
    #5
    Be sure that, just by leaving "install ipad baseband" unchecked, that the new redsn0w is defaulted to keeping your current baseband as opposed to using the baseband inside the stock 4.2.1 that it is working off of. I've read about redsn0w that it upgrades your baseband; if that is only an accurate description of redsn0ws past, and not this new special deal :confused:
     
  6. Junkboxy macrumors member

    Joined:
    Sep 17, 2008
    #6
    Read here to get your fill of instructions from the horse's mouth. These are the guys who make redsn0w and Pwnage Tool.

    http://blog.iphone-dev.org/
     
  7. keerti thread starter macrumors newbie

    Joined:
    Nov 7, 2010
    #7
    thanks or the advice guys , but can someone tell me if i leave the "install ipad baseband " unchecked , will it still change the bb to the one which is packed inside the ios 4.2.1 file ?
     

Share This Page