iOS 4.2 changed Gmail 'Delete' to 'Archive' (pic)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by coolwater, Oct 17, 2010.

  1. coolwater macrumors 6502a

    coolwater

    Joined:
    Jun 8, 2009
    #1
    How do I change it back to [Delete]? I've looked into every option/setting in both ends but to no avail.
     

    Attached Files:

  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    I think this changed to Archive in 4.0 and tapping that button does the same thing as it did when it said Delete.
     
  3. coolwater thread starter macrumors 6502a

    coolwater

    Joined:
    Jun 8, 2009
    #3
    Are you sure? I think it actually 'archives' emails rather than 'deleting' them.
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    Pretty sure. At least it does what it always has for my GMail account.
     
  5. techpr macrumors 6502

    techpr

    Joined:
    Sep 9, 2008
    Location:
    San Juan, PR
    #5
    You can change back to "Delete" on iOS Settings

    Settings > Mail, Contact, Calendars > GMail Account > Archive Message "OFF"
     
  6. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #6
    Gmail's IMAP implementation is really weird. If I tap the garbage icon in a message, it will archive the message, not delete it. If I swipe to delete, and confirm, it will archive the message not delete it. I think that's why Apple changed it to archive instead of delete. MobileMe is much better in this respect, it just works.
     

Share This Page