iOS 4.2 GM iPod and Video Issues

Discussion in 'iPad' started by tevans333, Nov 2, 2010.

  1. tevans333 macrumors member

    Joined:
    Apr 13, 2010
    #1
    Hey all, I just installed the 4.2 GM release and have an issue with my iPod and Video player. It just says canceling Sync and stays there indefinatly. I had this same problem with Beta 3 and just thought it was a beta issue, but now that it is still there in the GM I am curious if it is something on my end. When I rollback to 3.2.2 it works just fine without issue. Any help would me much appreciated. Below are some screenshots of both:
     

    Attached Files:

  2. the-sandman macrumors regular

    the-sandman

    Joined:
    Apr 17, 2009
    Location:
    Leicester, UK
    #2
    What version of iTunes do you have? You need the 10.1 beta to actually sync media.
     
  3. tevans333 thread starter macrumors member

    Joined:
    Apr 13, 2010
    #3
    Yes, I've installed the 10.1 beta, it is listed as 10.1b10 in itunes.
     
  4. tevans333 thread starter macrumors member

    Joined:
    Apr 13, 2010
    #4
    For anyone having this issue I have found a fix.

    First you must upgrade from 3.2.2 to 4.2 if you are not a developer. If you restore to 4.2 you will not be able to validate your install. That being said, if you have media synced already and upgrade you may have this issue. I restored to 3.2.2 then upgraded to 4.2 then added my media and all is well. Of course the draw back is I have lost all of my App data and settings, so do this based on your own preference.
     
  5. spacepower7 macrumors 68000

    Joined:
    May 6, 2004
    #5
    If I am reading this correctly....

    iTunes 10.1b
    Restore not upgrade 4.2GM with non developer registered iPad
    This caused your sync issues?

    Just checking because I'm in the same situation. Free dev not registered.

    Did you have any problem with folders?

    So did you downgrade from a 4.2betaX to iOS3.2.2 then upgrade or restore to iOS 4.2GM?

    Thanks for any input that might save me an hour and a headache :)
     
  6. lbeck macrumors 6502

    lbeck

    Joined:
    Dec 5, 2009
    #6
    The easy fix for me was to just sync the ipad again, all me videos and music came through this time. For some reason it did not do it the first time and I got the same screens that you did.

    Go ahead and sync your ipad again and see if it fixes it. Much easier than restoring and losing app data and such. Hope it works for you
     
  7. Saberon macrumors 6502a

    Joined:
    Sep 16, 2008
    #7
    Here's my steps to success

    Install iTunes 10.1 beta 2

    Reboot

    Restore to 4.2

    Done
     
  8. tevans333 thread starter macrumors member

    Joined:
    Apr 13, 2010
    #8
    I tried to sync many times as well as reboot to no success. This is a last resort method for those who need it.
     
  9. lbeck macrumors 6502

    lbeck

    Joined:
    Dec 5, 2009
    #9
    Wow, that stinks. I definitely got lucky then. I love 4.2, it is perfect for the ipad. cant believe it took apple this long to get it out.
     
  10. Bobajobbob macrumors regular

    Joined:
    Oct 11, 2005
    #10
    I did an upgrade using the iTunes beta 10.1 and had this issue before I performed a sync.

    Post sync media displays just fine.
     
  11. lbeck macrumors 6502

    lbeck

    Joined:
    Dec 5, 2009
    #11
    Thats cool, its not just me then. Hopefully most people will be able to do what we did.
     
  12. Grego23 macrumors newbie

    Joined:
    Nov 4, 2010
    Location:
    Montréal, QC
    #12
    Had the same problem, as well. I confirm that synching a second time after the ios has been updated fixes the issue. I was worried there for a sec, but all is well.
     

Share This Page