iOS 4.3 breaks Wireless N (802.11n) on 2.5 and 5ghz bands for iPad, atv2, and iPhone4

Discussion in 'iPad Tips, Help and Troubleshooting' started by dduttonnc, Mar 12, 2011.

  1. dduttonnc, Mar 12, 2011
    Last edited: Mar 12, 2011

    dduttonnc macrumors member

    Joined:
    Mar 11, 2011
    #1
    It's not just in the 5ghz band as I first thought.

    I put 4.3 back on things and did more tests..

    4.3 prevents ANY iDevice , including the ATV2 from using 802.11n in any band.

    Many ppl don't see this because their routers are in mixed mode. So for 5ghz ppl , the devices drop to 802.11a, and for 2.4ghz ppl, the devices drop to G.

    I hate mixed mode on routers because it degrades performance(so I don't use it). So my 5ghz band is N only and my 2.4 is G only. So I noticed this right away. But once I set my 2.4ghz to n only mode , no idevice running 4.3 could connect to any band. nothing would touch it

    This also is not a 40mhz vs 20 issue as my 5ghz was forced to 40 and the iPad and ATV used it just fine under 4.2.1, and i tried 20mhz N only on both bansd and still nothing would connect.

    I'm a computer engineer and programmer so I troubleshooted every possible cause with this affecting all idevices, and what I see on the forums this is a HUGE screw up in the release of iOS 4.3

    I'm just shocked there are NO press releases. 54Mbit is not enough to stream HD movies to an iPad. The iPad does not buffer to storage like the ATV2, it buffers to ram. So on a G/A network, HD video streams to my iPad then stops every 1-2 mins

    However, I was able to downgrade everything to 4.2.1 again because apple is still signing it

    If anyone else wants to test this put u router in N only mode for both bands and watch what any iDevice will do (or won't do) ;)

    EDIT: most airport extreme users not affected
     
  2. OmegaRed1723 macrumors 6502

    OmegaRed1723

    Joined:
    Jun 19, 2009
    Location:
    The Waste
    #2
    I have an iPad1, an iPad2, and an :apple:TV2 all running the latest iOS release working just fine. I use an Airport Extreme Base Station with a dedicated 5GHz N only network, so if there were any issues, the devices would be unable to connect.
     
  3. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #3
    My iPad rev1 iOS 4.3 works fine with Airport Extreme on 5GHz.
     
  4. dduttonnc thread starter macrumors member

    Joined:
    Mar 11, 2011
    #4
    Forgot to mention. Airport users are unaffected. This affects linksys, cisco, and netgear

    This is still huge as those are major router makers
     
  5. OmegaRed1723 macrumors 6502

    OmegaRed1723

    Joined:
    Jun 19, 2009
    Location:
    The Waste
    #5
    If true, that is indeed a glaring problem. I agree that N is really necessary for proper streaming of HD video. No way I would be able to do it over an 'a' or 'g' connection.
     
  6. dduttonnc thread starter macrumors member

    Joined:
    Mar 11, 2011
    #6
    I just got off the phone with tier 2 apple support. This issue is CONFIRMED. Support says this issues affects all non apple routers and "some" airport routers (probably older ones)

    They said it will b fixed but to "wait a few weeks"

    screw that. I downgraded my atv2 back to 4.2.1 before they stop signing it and boom.. It connected right back to 5ghz N at 40mhz channel width

    I left 4.3 on the iPad
     
  7. PoitNarf macrumors 65816

    PoitNarf

    Joined:
    May 28, 2007
    Location:
    Northern NJ
    #7
    Just set my FiOS Actiontec router to 802.11n only, my iPad2 is still able to connect successfully.
     
  8. dduttonnc thread starter macrumors member

    Joined:
    Mar 11, 2011
    #8
    Issue solved. Apparently iOS 4.3 REQUIRES WMM support to be ENABLED or it will refuse connect to a dedicated N router or it will fall back to G on a mixed mode router. I read the final IEEE 802.11n requirements and it hinted WMM is now mandatory.

    WHY apple would force this w/o telling ppl is a mystery. But once I enabled it, all my idevices can now do 2.4 and 5gz N again on iOS 4.3
     
  9. Kadman macrumors 65816

    Kadman

    Joined:
    Sep 22, 2007
    #9
    I have 2.4 running mixed and 5 running N-only and didn't notice it even on my 5 ghz network. After your last post I check dmy configs and had WMM already enabled. I'm using Linksys E3000 routers (large coverage area) but I'm using DD-WRT firmware. WMM was enabled by default.
     

Share This Page