iOs 4.4.4 and XBMC

Enigmafan420

macrumors 6502a
Original poster
Apr 18, 2008
896
0
Puget Sound, U.S.A.
Okay so I FINALLY upgraded to iOS 5.X for Apple TV 2 today and Jailbroke with Season Pass. Got everything installed, including Firecore, except XBMC won't install.

I think the error message I saw was something along the lines of device full.

Is this possible? I have never been told I was out of memory before.

Anyone know how to get around this issue?

----------

Here is the error message I get from terminal:

Unpacking org.xbmc.xbmc-atv2 (from .../org.xbmc.xbmc-atv2_11.0-0~b1_iphoneos-arm.deb) ...
dpkg: error processing /var/cache/apt/archives/org.xbmc.xbmc-atv2_11.0-0~b1_iphoneos-arm.deb (--unpack):
failed in buffer_write(fd) (7, ret=-1): backend dpkg-deb during `./Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/backgrounds/appearance.jpg': No space left on device
dpkg-deb: subprocess paste killed by signal (Broken pipe: 13)
Errors were encountered while processing:
/var/cache/apt/archives/org.xbmc.xbmc-atv2_11.0-0~b1_iphoneos-arm.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

ajohansson

macrumors regular
Dec 5, 2011
140
7
This topic is all over the Firecore forum. Some have issues some don't. I did see a fix in there about doing some terminal commands. Unfortunately Im not at home so I can't try it myself. Per fire core the newest version of the Untethered JB is supposed to support XBMC install from the maintenance menu and you should not have to SSH. Im mean that the point of FIrecores ATV Flash Black is to not have to use terminal. The last tethered JB required SSH terminal for for XBMC.
 

Laserwash

macrumors newbie
Dec 31, 2011
1
0
There is room on your "drive" you just have to put it in a "directory" that you can write to.

http://forum.xbmc.org/showthread.php?p=971675

Follow what Jester posted here. It worked for me.

I had similar problems when trying to install and then again when I was trying to put add ons for XBMC. I'm up and running now though.
 

Atlantean

macrumors member
Dec 26, 2011
32
2
Dublin, Ireland
I did a jailbreak last night and installed aTV (black) a few minutes ago. I then installed XBMC which did have an error on my first go. I rebooted the Apple TV and it installed without a hitch :D
 

cooa99

macrumors regular
Sep 30, 2011
120
2
I am having problems jailbreaking on 4.4.4

every thing works fine until the itunes restore and I get error 1604 ...( Unknown error occured...)

Same issue twice now.

Anyone getting this?

cooa99
 

hafr

macrumors 68030
Sep 21, 2011
2,743
5
Okay so I FINALLY upgraded to iOS 5.X for Apple TV 2 today and Jailbroke with Season Pass. Got everything installed, including Firecore, except XBMC won't install.

I think the error message I saw was something along the lines of device full.

Is this possible? I have never been told I was out of memory before.

Anyone know how to get around this issue?

----------

Here is the error message I get from terminal:

Unpacking org.xbmc.xbmc-atv2 (from .../org.xbmc.xbmc-atv2_11.0-0~b1_iphoneos-arm.deb) ...
dpkg: error processing /var/cache/apt/archives/org.xbmc.xbmc-atv2_11.0-0~b1_iphoneos-arm.deb (--unpack):
failed in buffer_write(fd) (7, ret=-1): backend dpkg-deb during `./Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence/backgrounds/appearance.jpg': No space left on device
dpkg-deb: subprocess paste killed by signal (Broken pipe: 13)
Errors were encountered while processing:
/var/cache/apt/archives/org.xbmc.xbmc-atv2_11.0-0~b1_iphoneos-arm.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
The problem is that there is no space left on the device...

Most often this is because of cached videos. Delete the cache files (everything but the .plist) in /private/var/mobile/Library/Caches/AppleTV/Video/LocalAndRental and /private/var/mobile/Library/Caches/AppleTV/Video/Other

Does it work?

----------

I am having problems jailbreaking on 4.4.4

every thing works fine until the itunes restore and I get error 1604 ...( Unknown error occured...)

Same issue twice now.

Anyone getting this?

cooa99
Are you following a guide? If yes, could you please link it? If no, google one and follow it to the letter ;)
 

hafr

macrumors 68030
Sep 21, 2011
2,743
5
I am following Iclarified Windows Guide

The xbmc wiki link above or the whole site is dead at the mo

I will try the Mac version of the Iclarified link to see if that makes a Difference

cooa99
Okay. I've never jailbroken an ATV2 on a Windows machine. But have you installed the .net framework as it asks you to? Most often when people are experiencing trouble it's because they've overlooked something in the guide.

What you could do, if you've followed it to the letter and it still doesn't work, is to download the .ipsw manually. You then hold ctrl when clicking the Create IPSW button and choose the downloaded file.
 

steve5424

macrumors member
Sep 30, 2007
73
0
Glasgow, UK
I am having issues installing XBMC after installing NitoTV after a JailBreak

I keep getting an error about the no more updates plugin stating it can't be found and then the XBMC install stops. Have tried everything including SSHing into the ATV2 to manual remove the pop up but it still won't work.

Any advice?
 

JoeShades

macrumors 65816
Sep 1, 2010
1,017
254
Williamstown, NJ
The problem is that there is no space left on the device...

Most often this is because of cached videos. Delete the cache files (everything but the .plist) in /private/var/mobile/Library/Caches/AppleTV/Video/LocalAndRental and /private/var/mobile/Library/Caches/AppleTV/Video/Other

Does it work?



----------



Are you following a guide? If yes, could you please link it? If no, google one and follow it to the letter ;)


How do you clear the appletv cache :confused:
 

hafr

macrumors 68030
Sep 21, 2011
2,743
5
How do you clear the appletv cache :confused:
By deleting the cache files (everything but the .plist) in /private/var/mobile/Library/Caches/AppleTV/Video/LocalAndRental and /private/var/mobile/Library/Caches/AppleTV/Video/Other
 

Woody5250

macrumors newbie
Jan 13, 2014
2
0
Atv2 xbmc

Hi does any one now if I delete items from my folder

Private/var/cache/apt/archive

Will this effect any programs on my atv2 or xbmc
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.