iOS 4 Require Password "immediately" Only Option??

Discussion in 'iPhone' started by Ron21, Jun 25, 2010.

  1. Ron21 macrumors 6502a

    Sep 6, 2007
    Any way to fix this without trying to restore?

    Attached Files:

  2. Mosco macrumors regular

    May 26, 2002
    You don't have an exchange account set up do you? I am wondering if that is caused by an exchange policy.
  3. Ron21 thread starter macrumors 6502a

    Sep 6, 2007
    just google sync but I tried removing it and same issue.
  4. IAmTheCrack macrumors member

    Mar 25, 2009
    I remember having that issue around a year ago. I would try a reset all settings and then set up as a new phone if that doesn't work. Worked for me back when I had that problem.
  5. E3BK macrumors 68030


    Mar 15, 2008
    I'm having the same issue and can't figure out how to fix it. Very annoying. I was trying to find an answer before posting (you know how people hate duplicates on this forum) but not much is being said. This bug is being overshadowed by the reception issue. =(

    Autolock after 1 min = no bueno.
  6. Hoangsta macrumors member

    Jun 24, 2010
    Hmm, have you tried restore and setting up as a new device?

    It should have the options:

    After 1 Minute
    After 5 Minutes
    After 15 Minutes
    After 1 Hour
    After 4 Hours
  7. Ron21 thread starter macrumors 6502a

    Sep 6, 2007
    Trying to avoid restoring but will do if that is the only option.
  8. E3BK macrumors 68030


    Mar 15, 2008
    Additional note...I experienced this on my 3GS when I upgraded to 4.0 because well...I was too impatient to wait for the new iP4 to arrive 3 days later =P

    It had the same issue but I didn't have time to fix. I've reinstalled iOS4 on the 3GS, set up as new and added each email account (exchange, yahoo, mobileme, gmail regular, gmail google apps) one by one checking the autolock after adding each one.

    Autolock is normal on it now, I can choose 5 min. Am dreading having to do this on the new takes so long get get everything where I like it.
  9. luckygyrl83 macrumors 6502

    Jun 23, 2008
    Fullerton, CA
    For some reason, I don't have the immediately option. Very odd.
  10. penguintri macrumors member

    Jun 30, 2009
    Has anyone got a solution to this problem, because I am now having it on my 4?
  11. ipoddin macrumors 6502a


    Jan 6, 2004
    Los Angeles
    Odd. I have all of the options in my passcode settings.
  12. T4R06 macrumors 65816

    Oct 8, 2007
    There is no 4 hours option on mine. The maximum is 1 hour. I have my company setup email also.

    I really missed jailbreak on iphone, so you can download the killexchange via cydia.
  13. penguintri macrumors member

    Jun 30, 2009
    Im pretty sure it only started happening when I did a reset all settings on my phone, to fix a voicemail problem. It's quiet annoying. Might have to try a restore form backup to fix it. Hope its not a setting saved in my backup somehow!
  14. Sebby macrumors 6502a

    Dec 20, 2008
    London, UK
    Same here. Also the Auto-Lock menu is blank. Anyone else?
  15. E3BK macrumors 68030


    Mar 15, 2008
    I tried everything to fix this problem on the iP4, reset all setting, reset network settings, etc...but in the end I had to do a full restore and set it up as new. Took a long time w/ all the folders to arrange but auto lock is normal again.
  16. t22design macrumors regular

    Nov 10, 2007
    I did a clean restore to 'solve' the proximity sensor issue, and now my iPhone wants to 'Passcode Lock = immediately'.

    I love my iPhone 4. :confused:
  17. valkraider macrumors regular

    Apr 22, 2004
  18. cw2k7 macrumors member

    Jan 18, 2008
    Google sync doesn't provide an exchange security policy.

    The problem is caused by a change in the way the iphone handles lack of security policy.

    OS3.1.3 ignored the lack of policy.

    OS4 applies failsafe security settings when the policy is missing.

    Google are aware of the problem and are working on a fix.
  19. TuffLuffJimmy macrumors G3


    Apr 6, 2007
    Portland, OR
    Do you have an exchange account?
  20. danb77 macrumors 6502

    Sep 4, 2007
    I had this issue. I think it is due to corrupted settings from previous versions of iOS (did you ever jailbreak?) combined with a "reset all settings".

    There were assorted other symptoms too (e.g. Emoji keyboard wouldn't activate).

    I fixed it by setting up as a new phone…

    If I were you I'd wait for a 4.0 jailbreak and then use AppBackup to save your app data when you do the clean install...
  21. Ashin macrumors 6502a


    Jun 19, 2010
    I've always wandered... what is the point of requiring a passcode after a minute or 4 hours?

    What's the point in having a passcode, if someone can look at your stuff for a minute before having to put it in
  22. dekadent macrumors member


    Sep 30, 2009
    Stockholm, Sweden
    The point is that if I manage to hold on to my phone for at least a minute and a few seconds after I last used it, then someone who finds my phone will not be able to use it. Simple as that.
  23. maflynn Moderator


    Staff Member

    May 3, 2009
    Many companies enforce certain group policies for cell phones connecting to their exchange servers. If you set up your work email/exchange server then the odds are high this was the cause.
  24. zub3qin macrumors 65816


    Apr 10, 2007
    I did the reset all settings in an attempt to fix my proximity sensor issue.
    Now I am stuck with no PASSCODE LOCK timer.

    Out of curiosity, did anyone get their proximity sensor issue fixed by doing a full restore and setting up as a new iPhone? I assume it WILL fix the PASSCODE bug?
  25. jpur macrumors member

    Oct 15, 2008
    How to fix this issue

    Hey everyone,

    If this isn't being caused by an Exchange account or with a Google Apps gmail account, you can fix this issue by creating your own configuration profile using the iPhone Configuration Utility.

    Just make a new profile that has the passcode settings you desire and install.

    That should fix it!

Share This Page