iOS 5.0.1 carrier issues

Discussion in 'iOS 5 and earlier' started by Dondo, Nov 13, 2011.

  1. Dondo macrumors newbie

    Dondo

    Joined:
    Sep 17, 2007
    Location:
    London, UK
    #1
    Hello,

    After upgrading to 5.0.1 on my iPhone 4S I can't place or receive calls (Vodafone Romania carrier).
    I have replaced my sim and even used a different carrier (Orange Romania) sim with no luck.
    I have restored using iTunes but still can't get it to work.
    As you can see in the threads below this happens to a lot of international customers all over the world.
    Apple Discussions:
    https://discussions.apple.com/thread/3396554
    https://discussions.apple.com/thread/3425746
    https://discussions.apple.com/thread/3482725
    https://discussions.apple.com/thread/3430862
    Unfortunately Apple doesn't seem to admit there is an issue with 5.0.1 yet.
    I hope 5.0.2 comes quickly otherwise I am stuck with an overpriced iPod...
     
  2. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
    #2
    I've not had any problems with O2 here in the UK.
     
  3. Tiger8 macrumors 68020

    Joined:
    May 23, 2011
    #3
    Take it to Apple store, and make sure you don't leave until they solve it for you, or get you a new phone.
     
  4. biggy52 macrumors regular

    Joined:
    Oct 22, 2009
    Location:
    Tanzania (East Africa)
    #4
    Im having the same problems. I tried the phone in China and my country Tanzania. After upgrading to iOS 5.0.1 network keeps losing, calls show Call failed in the middle of the conversation, and network keeps going to Searching every hour.

    I got the Factory Unlocked phone from UK.

    I never had this issue on 5.0.

    I hope they fix this.
     
  5. PhoenixMac macrumors 65816

    Joined:
    Mar 7, 2010
    #5
    Guess I won't be updating while traveling abroad.
     
  6. circa macrumors member

    Joined:
    Oct 10, 2011
    #6
    I'm having a similar problem - I have to reboot my phone sometimes to be able to successfully make a call. I'm in the US using AT&T. Its kindof strange - the phone goes through the motions of making the phone call but you can't hear anything and no one can hear you.
     
  7. haXis macrumors member

    haXis

    Joined:
    Jun 8, 2010
    Location:
    Czech Republic
    #7
    well i don't have any problems until i go away from the city where there is a low 3g reception. than i have no service until i turn on and off the airplane mode
     
  8. Dondo thread starter macrumors newbie

    Dondo

    Joined:
    Sep 17, 2007
    Location:
    London, UK
    #8
    I have changed my SIM again and the problem seem to be solved (at least for the last 24 hours).
    It might be that this one is the new 128k sim that did the trick.
     

Share This Page