iPhone iOS 5.1.1 restore? iOS 6 upgrade? Nothing works!

Discussion in 'Jailbreaks and iOS Hacks' started by helios16v, Nov 26, 2012.

  1. helios16v macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    Earth
    #1
    My friend just bought a new non-iDevice and he's giving his old iPhone 4 to his father, of which he would like to restore his phone back to factory iOS 5.1.1

    His phone is currently on 5.1.1 and he has it jailbroken. We tried going into Settings > General > Reset > Reset All Settings but no avail. We tried restoring the iPhone to iOS 5.1.1 on his MacBook Pro running OS X 10.8.2 with iTunes 10.7 only to get Error 1600 which almost expected because iOS 5.1.1 is no longer signed with Apple for activation.

    We followed the iOS 6.0 to 5.1.1 downgrade method by using Rensn0w 0.9.14b2 to create our own custom restore using his saved 5.1.1 SHSH BLOB, we put the iPhone into Pwn DFU mode and still managed to get Error 1600.

    We then figured this method is probably designed to be used from an iPhone on iOS 6.0, at this point we decided to use his MacBook (as we've altered the host file on his currect MacBook Pro). His MacBook is running OS X 10.6.8 and iTunes 10.7, we put the iPhone into DFU mode and tried to restore to iOS 6.0 only to get an error telling us The iPhone not eligible for requested build.

    I'm really at a loss here, we just spent the last 3 hours trying to do this and we can't even upgrade this iPhone to iOS 6 let alone restore it, it's stuck on iOS 5.1.1 with all of his information and no way to restore.

    Any ideas?
     
  2. dinggus macrumors 65816

    Joined:
    Jan 17, 2012
    #2
    If his blobs are saved via cydia, use Tiny Umbrella and retrieve them and then make your custom firmware.

    Try running Tiny Umbrella and "kill" iTunes from trying to connect to the Apple server.

    Have you tried directing the host file to Saurik's server?
     
  3. helios16v thread starter macrumors regular

    Joined:
    Nov 1, 2008
    Location:
    Earth
    #3
    We used the stitch function on Redsn0w 0.9.14b2 to stitch the 5.1.1 ipsw with the 5.1.1 SHSH Blob that was backed up on the Cydia server to make our custom ipsw but it didn't work even when we were in Pwn DFU mode like a few tutorials suggested, we still got error 1600.

    We edited the hosts file manually to do this, that's why we switched over to the untouched MacBook running OS X 10.6.8 so we could update properly to an untouched iOS 6.0

    Updating to iOS 6.0 will not work on either OS X 10.6.8 MacBook on iTunes 10.7 with untouched host files, as well as the OS X 10.8.2 MacBook Pro on iTunes 10.7 and blocked host files.

    Apple support site suggested that the error telling us the iPhone not being eligible for requested build is a result of iTunes being blocked with the hosts file which is why we moved over to the untouched OS X 10.6.8 MacBook
     
  4. dinggus macrumors 65816

    Joined:
    Jan 17, 2012
    #4
    I have never heard of this issue out of all the iPhone's that I have had since 3GS and jailbreaking friends phone's as well. The only issue I had with iPhones was when I upgraded my 3GS baseband to the iPad, it was a pain to upgrade if I wanted to.

    Try this:
    http://www.regmender.com/how-to-fix-itunes-error-1600.html
     
  5. braxton34 macrumors member

    Joined:
    Mar 18, 2012
    #5
    Are you trying to update to 6.0 ?
    Because 6.0.1 is the latest iOS, which may explain the error.
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    Use redsn0w 0915b3

    Download the ios you want to restore
    Connect phone
    In redsn0w go to extras/even more/restore

    Select your ipsw
    Select remote blobs and follow instructions

    The host file must point to apple
    Type in gs.apple.com in your browser on your mac, it should go to an apple site.

    For 6.01 put phone in DFU and hit restore in itunes
     
  7. pedromagico macrumors newbie

    Joined:
    Nov 26, 2012
    #7
    I just bought an IPHONE 4S 5.1 (9b179) 64gb.

    What should I do?
    I mean.. I have no blobs or anything.. Can't downgrade nor update ..

    Any information will be very very helpful!

    Thanks :)
     
  8. AppleFanatic10 macrumors 68030

    AppleFanatic10

    Joined:
    Nov 2, 2010
    Location:
    Encino, CA
    #8
    If you don't have any SHSH blobs than it's impossible to downgrade. Is your iPhone 4S jailbroken? That might be the problem. I'd try a restore.

    ----------

    Ugh, I hate error 1600. I watched this video to downgrade my iPhone 4, it may help. I know you're not on iOS 6 but it may help you with 5.1.1
     
  9. pedromagico macrumors newbie

    Joined:
    Nov 26, 2012
    #9
    Thanks for the anwser, AppleFanatic10!

    But as I said, I just bought it (got it yesterday).
    I had an iPhone 4S before and it was jailbreaked and everything but unfortunatly it was stolen!

    If I do an Restore it'll install the IOS6 and that's not quite a good idea, isn't it?
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    You got no option besides stay on 5.1 or update to 6.0.1
    What are your intentions anyway?
     
  11. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #11
    That depends on what your objective is.
    You cannot upgrade to any firmware but 6.0.1 unless the former owner saved hash files (TinyUmbrella to check)
    You cannot jailbreak on 5.1 and never will be able to do so.
    Since you will be waiting for a jailbreak regardless, you may just wish to enjoy the newest firmware while waiting.
     
  12. pedromagico macrumors newbie

    Joined:
    Nov 26, 2012
    #12
    Ok guys, thanks for the help!

    Guess I'll stay with my 5.1 version and wait for a ios6 jailbreak, right?
    (I dont see any reason to update do ios6.)
     
  13. BFizzzle macrumors 68020

    BFizzzle

    Joined:
    May 31, 2010
    Location:
    Austin TX
    #13
    well other than.. apple pushing out ios 6.1 and IF 6.1 happen to close the exploits used for ios 6.0/0.1 JB.


    then you would only be able to update to 6.1.. and miss the 6.0/.01 JB
     
  14. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #14


    So save your 6.01 SHSH!!!
     
  15. BFizzzle macrumors 68020

    BFizzzle

    Joined:
    May 31, 2010
    Location:
    Austin TX
    #15
    but i thought you had to be on 6.0/6.0.1 to save them? hes on 5.1
     
  16. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #16
    nope, you can save any currently signed iOS SHSH's even if you are not on that current firmware.
    Use TinyUmbrella to save them locally.
     
  17. BFizzzle macrumors 68020

    BFizzzle

    Joined:
    May 31, 2010
    Location:
    Austin TX
    #17
    awesome idk that.. thanks.
     
  18. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #18
    You're learning grasshoppa:D
     
  19. BFizzzle macrumors 68020

    BFizzzle

    Joined:
    May 31, 2010
    Location:
    Austin TX
    #19
    Miyagi: Man who catch fly with chopstick accomplish anything.
     
  20. AppleFanatic10 macrumors 68030

    AppleFanatic10

    Joined:
    Nov 2, 2010
    Location:
    Encino, CA
    #21
    AH! Sorry didn't read that you just bought it lol. Yes, if you do a restore then you'd have no choice but to upgrade to iOS6. And isn't the jailbreak for 5.1.1 the same for 5.1?
     
  21. pedromagico macrumors newbie

    Joined:
    Nov 26, 2012
    #22
    Amazingly Absinthe only jailbreaks 5.1.1 and not 5.1 (quite bad, isn't it?)

    Guess Ill save my SHSH thing and then update to ios6 and then save it too!

    Whaddya guys think?
     
  22. jinx1000 macrumors member

    Joined:
    Jul 12, 2010
    #23
    I don't think there's an exploit yet to take advantage of the 6.0.1 blobs. Might be worth upgrading just in case. A jailbreak doesn't guarantee being able to upgrade to 6.0.1 if apple stops signing it even if you have the blobs.
     
  23. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #24
    Blobs for 5.1 can't be saved anymore.
    You can save your 6.01 SHSH while on 5.1

    Once you upgrade to 6.01 you'l be stuck there on a 4S
     
  24. pedromagico macrumors newbie

    Joined:
    Nov 26, 2012
    #25
    Guys, I'm quite new in this SHSH and Blobs (bobs?lol) thing!

    What do you mean by:
    "You can save your 6.01 SHSH while on 5.1"

    How do I do that?
    I have the last version of RedSn0w and Absinthe here.

    Thanks! :)
     

Share This Page