iOS 5 Beta 3 - Facebook photo uploading?

Discussion in 'iPhone' started by Travisimo, Jul 13, 2011.

  1. Travisimo macrumors 6502a

    Joined:
    Dec 22, 2009
    #1
    Running iOS 5 Beta 3 on my CDMA iPhone 4. Having trouble uploading photos using the Facebook app. Worked fine in Beta 1 + 2, but now when I try to choose a photo from my library, it says it can't upload and asks to try again later (which I do, and it does the same thing). It simply won't upload any photos.

    So I tried downloading iLoader2 and it crashes when choosing a photo from the library. So I'm wondering if there's a bug in the Photos API or if it's just a compatibility issue with these apps?

    Anyone else experiencing this issue? Yes, I will report the problem at the Developer site, but wanted to see if it's just me first or if it's widespread.

    Thanks!
     
  2. jackhdev macrumors 6502

    Joined:
    Apr 9, 2011
    Location:
    Bismarck, North Dakota
    #2
    Yes, I've been having problems with FaceBook, too. I don't know how to fix it though...
     
  3. Frenchjay macrumors 68000

    Frenchjay

    Joined:
    Jul 6, 2010
    #3
    Facebook is all ove the show at the moment no matter what you have installed. They need to take their finger out and get it fixed. :rolleyes:
     
  4. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #4
    Interestingly, I can get photos to upload from the Photo Stream, but not from the Camera Roll. I've taken about 20 photos on my iPhone 4 since upgrading to Beta 3 earlier this morning. Only about 6 of them have appeared in my Photo Stream (which is turned on, of course), and those photos will upload via Facebook. But if I try to upload the same photos from the camera roll library, it gives me an error.

    Very strange... I can still take a photo while checking into Foursquare, but I can't choose a previously taken photo there either (the photo just does not upload with the checkin if I try to do it that way).

    Definitely something going on with the camera roll or Photos API.
     
  5. Frenchjay macrumors 68000

    Frenchjay

    Joined:
    Jul 6, 2010
    #5
    There seems to be a bug in the photo.app because you cannot set your wallpaper or lock screen image from within the photo app. Submit your bugs to Apple so they can resolve it :)
     
  6. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #6
    Can anyone successfully upload photos using the Facebook app with iOS 5 beta 3?
     
  7. Frenchjay macrumors 68000

    Frenchjay

    Joined:
    Jul 6, 2010
    #7
    I deleted Facebook and reinstalled it today and uploading photos seems to work ok.
     
  8. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #8
    I tried this but it didn't not work. If you don't mind, could I ask a couple of followup questions:

    1) Did you reboot before re-installing the Facebook app after deleting it?

    2) Did you upload a photo that you took on the phone after installing beta 3 (from your Camera Roll)?
     
  9. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #9
    Well, I tried everything short of doing another restore and it still isn't working. Oh well, at least I can still upload photos that appear in my Photo Stream for now. There must be something messed up with my Photos app.
     
  10. Travisimo thread starter macrumors 6502a

    Joined:
    Dec 22, 2009
    #10
    UPDATE:

    Just wanted to let everyone know that someone on the dev forums found a work-around for this Facebook photo uploading issue:

    You simply go into your iPhone settings and turn Location services off for the Facebook app. Then you will be able to upload photos via the Facebook app. This bug did not exist in Beta 2, so I'm hoping Apple will figure out what's going on. I updated my bug report in the dev bug reporter to include this new information.
     
  11. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
  12. AlphaDogg macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
    #12
    I had the same issue in iOS5.0b3. I ended up just emailing the pictures to myself and uploading them from my MBP. But I'm glad it's fixed in b4. I'm downloading it on my phone right now. I hope OTA updating works well :).
     
  13. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #13
    OTA worked fine, i had a problem after downloading whre it wouldn't install saying not connnected to internet, but flicking into airplane mode then out then installing worked fine.

    as for the facebook issue on beta 3, the location services trick worked for me, but no need for that now
     
  14. AppleFanatic10 macrumors 68030

    AppleFanatic10

    Joined:
    Nov 2, 2010
    Location:
    Encino, CA
    #14
    Funny because I can set my wallpaper/lock screen image from the photo app. Maybe you need to restore..:
     

Share This Page