iOS 5 beta 6: Issues with MobileSubstrate?

Discussion in 'Jailbreaks and iOS Hacks' started by soco, Aug 30, 2011.

  1. soco macrumors 68030

    soco

    Joined:
    Dec 14, 2009
    Location:
    Yardley, PA
    #1
    This is not an attempt to solicit help. I am not a developer, but my friend (a chick, no less) is, and for the life of her doesn't know much about developing for Cydia. Nonetheless, I'm just trying to get an idea about the latest beta if any of you have been toying with the latest jailbreak for it.

    Her phone is successfully jailbroken to the point where Cydia opens and things can be downloaded and installed, however, anything (it seems) that requires MobileSubstrate (again, it seems, we don't know) causes issues.

    Example:
    Fresh install of iOS Beta 6.
    Clean boot and shutdown.
    Load up redsn0w and jailbreak.
    Tethered boot.
    Open Cydia and refresh stuff.
    Navigate to MyWi and install.
    Reboot.
    See the Apple logo and hold Power and Home and get into DFU.
    Use redsn0w to boot tethered.

    At this point, nothing works. Stock apps or jailbroken. Even third party apps. Everything will just open and crash right away as if we forgot to do a tethered boot, but we didn't.

    We've tried reapplying the jailbreak, re-booting again, tethered, restoring the phone again, etc. and can't think of anything. She's even gone as far as to say, "I'm just gonna do this on the Inspire." - That scared me... I even put the beta on my personal phone and did this (I have a tester phone with beta 6 on it but I don't want to jailbreak it as I have a test-app from another buddy on it) and experienced the same exact thing just to eliminate it being her particular boot or something.

    Anyway, again, I'm not asking for assistance but mainly pointing out the intriguing issue as with all of my experiences with beta jailbreaks and the like, I've never run into this one and figured it may be an interesting point of discussion. After all, the whole point of toying with this in the first place was for her to learn something, so why not? :)
     
  2. Senseotech macrumors 6502a

    Senseotech

    Joined:
    Nov 23, 2009
    Location:
    Wilkesboro, NC
    #2
    Its most likely a MyWi issue, as I have beta 6 jailbroken and MobileSubstrate is installed and the phone works just fine. A lot of stuff changes in iOS 5, so I went into the jailbreak expecting even most simple things to be broken, and assumed anything in the low-level mucking like MyWi would be totally FUBAR until iOS 5 went GM or later.
     
  3. soco thread starter macrumors 68030

    soco

    Joined:
    Dec 14, 2009
    Location:
    Yardley, PA
    #3
    I agree. She has since been playing with Android development (God help her) and the phone is now unjailbroken sitting in a drawer lol

    Oh well.
     

Share This Page