ios 5 beta 6 photo restoring problem

Discussion in 'iPhone' started by lonman06, Aug 19, 2011.

  1. lonman06 macrumors regular

    Joined:
    Feb 23, 2010
    #1
    Anyone else getting the "restoring photos" at the bottom of the screen when opening up the photos app. All my photos are there, but it constantly says restoring. Have tried everything to get rid of it including turning off icloud and photostream and it is still there. Anyone else having problems like this?
     
  2. leanne.. macrumors member

    Joined:
    Apr 20, 2011
    #2
    nope, mine says syncing 0 of 320 and the icon just keep spinning and stays at 0
     
  3. Ferrd macrumors regular

    Ferrd

    Joined:
    Jan 24, 2008
    #3
    Count me in. Mine says restoring 0 of 648 and it will not go away.
     
  4. Ron21 macrumors 6502a

    Joined:
    Sep 6, 2007
    #4
    same here...

    IF anyone finds a fix, please post.
     
  5. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #5
  6. Izzy35 macrumors newbie

    Joined:
    Oct 25, 2010
    #6
    I have the same problem and it's annoying the heck out of me! And I do believe there will be an issue with this because when you perform a "BACKUP" the glitch is also saved. So going forward, every time you do a backup, it will continue to save and I'm not sure how any updates will get rid of it. The only way I got mine to disappear was restoring from a backup that I performed BEFORE doing the beta 6 update.

    If any of you have any better solution, please share. :)
     
  7. tmaxxtigger macrumors member

    Joined:
    Sep 12, 2010
    #7
    Got it working

    Try having the photo app open, then sync with iTunes. This working for me, the syncing was 0 of 540 then suddenly changed to 50 of 540, etc. Hope this works for everyone.
     
  8. Izzy35 macrumors newbie

    Joined:
    Oct 25, 2010
    #8
    For some reason mine is stuck trying to restore 29 photos. So regardless of how much it syncs or how many more pics I take, the difference between what it actually synced and what it continues to try and sync is 29. So right now, even after doing what you recommended, it's still stuck at "Restoring 0 of 29". This is pissing me off. more so because the glitch is being saved in the backups. So i don't know whether to restore it from a backup prior to beta 6 or to just leave it and hope that beta 7 fixes it.
     
  9. bimmahh macrumors newbie

    Joined:
    Feb 12, 2011
    #9
    sync issue

    same problem here.. what worked for me, YMMV

    1) remove the photo sync option ie let itunes delete the folders/pics
    2) Reboot the phone
    3) connect the phone to itunes
    4) enable the photo sync and let it copy them to the phone

    This worked for me and good luck..
     
  10. willsoriano macrumors member

    Joined:
    Mar 21, 2011
    #10
    I think i managed to fix mine by backing up to iCloud then logging into my mobile me find my iPhone and remotely erasing my phone. Right now I'm restoring from the iCloud back up and so far all seems to be running smoothly, although it did pop up a message about not being able to restore all .... but my stupid thumb pressed the all too easy to click close button before I could finish.

    oh well.
     
  11. SirithX macrumors 6502

    SirithX

    Joined:
    Feb 21, 2007
    Location:
    San Francisco
    #11
    This happened to me, but my photos wouldn't sync at all. So it said that and I had no photos. In order to make the photos sync, I had to go into the iPhoto Library and delete the iPod Photo Cache, and this not only fixed the photo syncing issue but also the restoring photos thing in the app.
     
  12. Izzy35 macrumors newbie

    Joined:
    Oct 25, 2010
    #12
    But here's my question to all those that have a solution. When u restored from back up, was it s backup from prior to updating to beta 6? I ask this bc I can "fix" it by just restoring from a backup prior to updating.
     
  13. bimmahh macrumors newbie

    Joined:
    Feb 12, 2011
    #13
    I didn't restore from backups just deleted, reboot and rsync'd the photo library

     
  14. Izzy35 macrumors newbie

    Joined:
    Oct 25, 2010
    #14
    Well this is an interesting find. I followed ure 1-4 steps above. After unchecking the SYNC box in iTunes, it asked to remove photos from phone and I said YES. i rebooted and hard resetted and the photos are STILL on my phone!!! So I basically never even got to the point of re-selecting the photos to sync. Nice ay??

    IDK what's going but this is annoying me.
     
  15. cshearer macrumors regular

    Joined:
    Aug 1, 2011
    #15
    Beta is beta, oh well.

    I didn't even notice this until reading this thread, and I consider myself much of photography nut, my iPhone being my digital camera. Just wait it out, you surely have more important things to concern yourself with.
     
  16. willsoriano macrumors member

    Joined:
    Mar 21, 2011
    #16
    Yeah, that didn't work. Nor did deleting all my photos then reinstalling iOS from the ipsw file. Really, I feel like they keep going backwards with these releases.
     
  17. rmead001 macrumors member

    Joined:
    Jul 12, 2009
    #17
    I had the same problem. What I did was download the iphone manager and delete the files that contained the caching data or whatever (I googled the problem and it was one of the first few hits). After this I restarted the phone and it rebuilt my camera roll. I then had an issue getting my sync pics back over. What ended up working was unchecking the sync button, apply. Re checking it and syncing all of my folders individually (I only sync a few) which put them all there with no photos. I then chose just the folders I actually wanted, hit apply/sync and it started copying all my photos over like normal. Good to go.
     
  18. benfica88 macrumors regular

    Joined:
    Nov 21, 2008
    #18
    Syncing a couple of folders at a time for me also worked.
     
  19. lonman06 thread starter macrumors regular

    Joined:
    Feb 23, 2010
    #19
    Still have the problem here. I do not have any folders on my iphone. Just the camera roll. Any advice?
     
  20. byke macrumors 6502a

    byke

    Joined:
    Mar 29, 2007
    Location:
    LDN. UK
    #20
    Any news?
    I cant seem to even delete or remove the corrupted photos via itunes.
     
  21. Vundu macrumors 65816

    Vundu

    Joined:
    Jun 10, 2009
    Location:
    Manchester, UK
    #21
    I am hoping the next beta sorts it. I can put up with it till then.
     
  22. spencers macrumors 68020

    spencers

    Joined:
    Sep 20, 2004
    #22
    Delete the photo cache. It worked for me a couple weeks ago when b6 came out.
     
  23. steve77uk macrumors regular

    Joined:
    Oct 28, 2007
    Location:
    UK
    #23
    I have been trying for a while to figure this out - I have no photo cache and use Aperture.

    What worked for me was to repair the permissions on my Aperture photo library by holding Apple and ALT when clicking on Aperture.

    It then started syncing. Aperture is closed whilst syncing - it may take some time to kick in.
     
  24. CavemanUK macrumors 6502

    CavemanUK

    Joined:
    Jun 29, 2006
    Location:
    Rhyl, North Wales
    #24
    I fixed my problem by deleting the photo cache. To do this, go to your pictures folder and right click on your iPhoto library. choose "Show Package Contents" and delete the folder "iPod Photo Cache". iTunes will rebuild it next time you sync. disclaimer: if this screws anything up, its not my fault! just saying it worked for me.
     
  25. lonman06 thread starter macrumors regular

    Joined:
    Feb 23, 2010
    #25
    I tried this, but didn't work. All I have on my phone is the actual camera roll, so that is never taken off...
     

Share This Page