iOS 5: Calendar "+" icon missing - cannot make any new entries

Discussion in 'iOS 5 and earlier' started by itsadc, Nov 8, 2011.

  1. itsadc macrumors newbie

    Joined:
    Jan 21, 2010
    #1
    Ever since upgrading my 3GS to iOS 5, the "+" icon/button from top of calendar application has gone missing. I cannot make any new entries into the calendar and that's frustrating.

    Google search gave me a result of turning on iCloud calendar feature and that returns the icon, but I do not want to use iCloud.

    Any other solutions?

    or will I have to give into Apple monopoly iCloud to use calendar on iPhone?
     
  2. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #2
    Can you post a screenshot of what you're seeing? I'm curious.
     
  3. jeans94621 macrumors regular

    jeans94621

    Joined:
    Jul 10, 2010
    #3
    Just hold down the date you want to add an event to and it will bring up the screen to create. It is a new feature which I am really enjoying. I use it daily and it makes things so much easier. I am enjoying ios 5 so much that I almost don't miss my jailbreak. Almost. :)
     
  4. TheMacBookPro macrumors 68020

    TheMacBookPro

    Joined:
    May 9, 2008
    #4
    Weird, I disabled my iCloud calendars leaving only my Gmail calendar checked and the + icon is still there.

    Try adding an iCloud account but uncheck it in the Calendar app and see if that works.
     
  5. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #5
    I don't know if this is possible but perhaps the only selected calendar is one that the OP is subscribed to but as "view only" or something to that effect.
     
  6. steveca macrumors 6502

    Joined:
    Mar 9, 2005
    Location:
    Malta
    #6
    try stopping the calendar app and then reloading it. Sometimes programs who misbehave can be fixed in this way
     
  7. itsadc thread starter macrumors newbie

    Joined:
    Jan 21, 2010
    #7
    Just tried this - however its not working. I kept the date pressed for 6 seconds.

    May be because I am on 3GS????
     
  8. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #8
    I don't think it's that as I'm on a 3GS and I'm not having any issues adding calendar entries.

    Can you provide additional details such as what types of calendars you have, which ones are selected, and which one is your default calendar under Settings>Mail, Contacts, Calendars?
     
  9. itsadc thread starter macrumors newbie

    Joined:
    Jan 21, 2010
    #9
    image

    Screenshot attached.
     

    Attached Files:

  10. itsadc thread starter macrumors newbie

    Joined:
    Jan 21, 2010
    #10
    I disabled my gmail calendar and it started working. Guess it has issues with having gmail calendar.
     
  11. r2shyyou macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #11
    Strange...thanks for posting the screenshot. If I may ask, how did you get the events on the 1st, 8th, and 14th onto your calendar?

    EDIT: just saw that you got it working.
     
  12. EvanLugh macrumors 68000

    EvanLugh

    Joined:
    Aug 29, 2007
    Location:
    Developer land
    #12
    this happened to me too, however with iCloud. I figured it was a bug. At the same time, i couldn't add any reminders in the reminder.app either. Had to remove and re-add the iCloud info to get it back.

    I spent a good few hours wondering why i couldn't add calendar entries, but thought i was probably having a whacky moment and over looking something. :eek:

    edit:r2shyyou in my case, they were already there from the previous calendar. the only thing unavailable was ability to add anything new.
     
  13. itsadc thread starter macrumors newbie

    Joined:
    Jan 21, 2010
    #13
    They are calendar entries from my previous calendar. Just adding a new entry doesn't work.

    Evan is right.

    However that brings me to a question, why didn't my iPhone allow me to choose a calendar type when I enabled Gmail calendar. If it would have, I would have seen my options and chosen the right one. (In fact just was talking to a colleague at work and saw on his iPhone that it allows him to pick which calendar he wants.)
     
  14. EvanLugh macrumors 68000

    EvanLugh

    Joined:
    Aug 29, 2007
    Location:
    Developer land
    #14
    honestly, personally i think it's a bug. I checked everything, turned all calendars on/off, tried pushing a new cal entry.. everything. Glad you've got it sorted now, though.
     
  15. Serenity95 macrumors newbie

    Joined:
    Apr 11, 2012
    #15
    I had this same exact problem. I completely deleted my Gmail account off my iPhone (the Gmail calender was already turned off). Immediately afterwards the "+" in my contacts and callenders reappeared. Thanks for the help guys!!!
     
  16. AlphaVictor87 macrumors 6502a

    AlphaVictor87

    Joined:
    Sep 7, 2011
    Location:
    Saint Louis, MO
    #16
    This is really cool! didn't know it was a feature!

    Also i know OP got it solved, but when i first had iCloud turned off i couldn't make new reminders. For some reason iCloud has to be ON in order to make new reminders which is stupid but whatever :D
     

Share This Page