iOS 5 on tmobile 3gs

iPhone007

macrumors newbie
Original poster
Nov 15, 2011
2
0
Hi all,
I just purchased an iphone 3gs and had it unlocked for tmobile. can i get iOS 5 on it? i have heard that there are some issues, and i am new to the whole cydia thing and have no idea how to use it. can someone tell me the best way to get ios 5 to work? thanks!
 

Trauma1

macrumors 6502a
Jun 15, 2009
585
2
I don't believe there are any untethered jailbreaks out for iOS 5 yet.

Until that happens, there aren't really any unlocking options for the 3GS on iOS 5. You need to have the jailbreak first before you can software unlock.
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,532
At the iPhone hacks section.
You will only be able to install 5.0.1 right now, not 5.0
And besides the tethered JB I heard ultrasnow doesnt play well with that firmware version so you might have problems not beeing able to unlock or use it on Tmobile.
 

djoz187

macrumors newbie
Jun 9, 2008
22
0
if you have the old bootrom 3GS then you can jailbreak with a custom IPSW using redsnow and then unlock with ultrasnow UNTETHERED. I am on it now and am loving it

*iPhone 3GS - Old Bootrom - Untehered Jailbroken Unlocked w/Ultrasnow iOS 5.0 - TMobile USA*
 

ylerT

macrumors regular
Jun 10, 2011
203
0
Las Vegas
Your best bet is to check the bootrom version on your 3Gs. If you're lucky enough to have the old one, it opens up a lot more options. We have a couple phones in right now with the old bootrom running an untethered jailbreak/unlock on both 5.0 and 5.0.1. So far we haven't run into any issues.

If you don't have the old bootrom, your best option is to stay with the software your on to keep your jailbreak/unlock and avoid issues. With the new bootrom, iOS 5 will be tethered and since your fairly new with this stuff, it will most likely cause more headache then you want to deal with.
 

jonnybgoode

macrumors newbie
Nov 20, 2011
1
0
Your best bet is to check the bootrom version on your 3Gs. If you're lucky enough to have the old one, it opens up a lot more options. We have a couple phones in right now with the old bootrom running an untethered jailbreak/unlock on both 5.0 and 5.0.1. So far we haven't run into any issues.
Joined just to ask you this question:
I have an old-bootrom 3GS and I accidentally updated to 5.0.1. I got it jailbroken again with redsn0w but because ultrasn0w hasn't been updated for 5.0.1 yet I cannot use tmobile, to my knowledge. What networks are you on or do you have another workaround for tmobile on 5.0.1 with an old-bootrom 3GS?
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,532
At the iPhone hacks section.
how do i know what bootrom my 3gs has? sorry im new to all of this
Use Idetector to determine if you got the old or newer bootrom.

Joined just to ask you this question:
I have an old-bootrom 3GS and I accidentally updated to 5.0.1. I got it jailbroken again with redsn0w but because ultrasn0w hasn't been updated for 5.0.1 yet I cannot use tmobile, to my knowledge. What networks are you on or do you have another workaround for tmobile on 5.0.1 with an old-bootrom 3GS?
Nothing as of now.
You will have to wait for ultrasnow to be updated in order to use it on Tmobile.
Try not to "accidentally" update your JB and software unlocked iphone again.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.