iOS 5 - Spam Mail not get a notification?

applefan27073

macrumors member
Original poster
Mar 13, 2011
32
0
Australia
Wirelessly posted (Mozilla/5.0 (iPod; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

I am getting heaps of spam to my gmail account now.
Whilst the messages go to the Spam folder, I cannot find a way for them to not give me a notification when they arrive. I enjoy having mail notifications for legit messages, but it does get annoying when I am constantly interrupted with useless notifications.

iPod Touch (4th Gen)
On the latest version of iOS 5 (5.0.1)
Gmail is the email service that the account is on, however I am accessing email through Microsoft Exchange.

Thanks
Jordan
 

AnionicStrength

macrumors member
Dec 28, 2010
75
0
Make sure you have the Spam not set to "Mail Folders to Push".

Settings > Mail, Contacts, Calendars > [Your Gmail Account] > Mail Folders to Push

 

Arelunde

macrumors 6502a
Jul 6, 2011
980
28
CA Central Coast
I had Gmail at first, but switched to iCloud's mail. Lovin' it - it works with the iCloud calendar and contacts (that I also set up after Gmail use). Makes things SOO simple and the instant sync is perfect.
 

penter

macrumors 6502a
Jun 15, 2006
600
29
Reviving this old thread...

Since true Push from Gmail was discontinued, your best bet is to disable your spam folder from syncing via IMAP on the server side of things.

If you want Push notifications from Gmail, you'll have to go for the paid Exchange service that they offer.

Here's what I've found:

https://discussions.apple.com/thread/4906235?start=0&tstart=0
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.