iOS 6 Beta 1 Jailbroken

BlaqkAudio

macrumors 6502
Jun 24, 2008
487
14
New York
Of course the exploit will work on iOS 6 final. It's the same exploit since iOS 4: limera1n. The real trick will be if they can find a way to jailbreak untethered.
 

ZCherub

macrumors 6502a
Jul 7, 2010
653
1
GA, USA
Of course the exploit will work on iOS 6 final. It's the same exploit since iOS 4: limera1n. The real trick will be if they can find a way to jailbreak untethered.
Are they using the limera1n exploit for A5 devices? I didn't think that was the case...
 

ZCherub

macrumors 6502a
Jul 7, 2010
653
1
GA, USA
MuscleNerd jailbroke an iPod Touch - A4 device.
As you stated, Limera1n will not work for any A5 or A5+ devices.
Got it - i don't use Twitter, so I don't get the updates as much. I wonder if the exploit that Absinthe used will work for the A5/A5+ devices... I'd like to get the iPhone "5" when it's released (presumably in the fall), but may hold off if a JB is way off. Of course, who knows if it'll have an A5 processor, & who knows what exploits will need to be found...
 

ACardAttack

macrumors 6502
Mar 18, 2010
398
0
HAHA...that didn't take very long! :D Hopefully, the exploit will still work on the final version. I wonder how many betas will Apple go through.
My guess is that exploit will probably be closed by then...I imagine it was the same hole from 5.1.1 that just hasnt been patched yet
 

Dwalls90

macrumors 601
Original poster
Feb 5, 2009
4,753
1,107
Of course the exploit will work on iOS 6 final. It's the same exploit since iOS 4: limera1n. The real trick will be if they can find a way to jailbreak untethered.
They won't bother until the GM drops, they won't burn any exploits on betas.

Are they using the limera1n exploit for A5 devices? I didn't think that was the case...
Nope, hence A4 or lower devices only (exploitable by limera1n)


My guess is that exploit will probably be closed by then...I imagine it was the same hole from 5.1.1 that just hasnt been patched yet
They can't close the jailbreak for A4 or lower devices because limera1n is a bootrom level exploit. They can keep it from being untethered though. There is no bootrom level exploit for A5+ hence the lack of even a tethered jailbreak for those devices.
 

ACardAttack

macrumors 6502
Mar 18, 2010
398
0
They can't close the jailbreak for A4 or lower devices because limera1n is a bootrom level exploit. They can keep it from being untethered though. There is no bootrom level exploit for A5+ hence the lack of even a tethered jailbreak for those devices.
Yeah, I meant more for the unteatheredness and A5 devices
 

Dwalls90

macrumors 601
Original poster
Feb 5, 2009
4,753
1,107
Yeah, I meant more for the unteatheredness and A5 devices
The 5.1.1 hole WAS closed in 6 beta, otherwise we would be able to jailbreak 6 on all devices untethered. So no exploits have been burned or wasted by releasing the dev jailbreak. Apple can't patch limera1n.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.