iPhone iOS 6 evaisi0n JB Apps using Maps/Location Crashing

Discussion in 'Jailbreaks and iOS Hacks' started by zmulleni, Feb 8, 2013.

  1. zmulleni macrumors regular

    zmulleni

    Joined:
    Jun 28, 2010
    #1
    Currently running iOS 6.1 evaisi0n JB on iP5 and I have been having issues with applications that access Maps or Location features. Anytime that the application goes to access these features it will cause the app to crash, close, and I am taken back to my home screen. I was wondering if there are others experiencing the same issue or if anyone has found a possible solution? I have all updates installed via App Store/Cydia and location services are turned on. The irony is that both native Maps app and Google Maps app work flawlessly. I have tried respring, reboot, and shutting off the device and restarting.

    Here is a list of known apps experiencing this issue:

    Gas Buddy
    The Weather Channel (when Map is selected)
    NOAA Hi-Def Radar
    Find my iPhone
    Apple Store

    Any help or insight on this is appreciated. Thank you!
     
  2. zmulleni thread starter macrumors regular

    zmulleni

    Joined:
    Jun 28, 2010
    #2
    Resolved - After hours of eliminating possibilities I discovered that the font that I was using through BytaFont was causing the apps to crash. Restored to original font through BtaFont and problem solved.

    Font being used in this case way Neutraface 2
     
  3. leocreo, Jul 14, 2013
    Last edited: Jul 20, 2013

    leocreo macrumors newbie

    Joined:
    May 18, 2008
    #3
    Having this same issue. Gonna try to restore the original font and see what happens.

    Edit: still facing same issue. Mainly in Sigalert app.
     
  4. leocreo macrumors newbie

    Joined:
    May 18, 2008
    #4
    Not certain how long the problem has been present but I know when it requests location and crashes it asks for it twice. Meaning the bubble pops up once, I click 'allow' and it pops up again. Then after clicking allow for a second time the app crashes back to the home screen. When an app is unaffected the request bubble only appears once.
     
  5. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #5
    Try deselcting all your JB tweaks/apps with either SBsettings or iCleaner Pro and enabling them 1by1 or in batches, it's probably a tweak causing the problem
     
  6. leocreo macrumors newbie

    Joined:
    May 18, 2008
    #6
    Thanks for the great suggestion. Gonna try that now.
     
  7. leocreo macrumors newbie

    Joined:
    May 18, 2008
    #7
    Tried the sbsettings method and immediately after going through the tweaks it seemed like I still had some crashing but since then I've gone about five days without any issues! So thanks again!
     

Share This Page