iPhone iOS 7.0.3 -> 7.0.4

Discussion in 'Jailbreaks and iOS Hacks' started by fizz7283, Jan 29, 2014.

  1. fizz7283 macrumors 6502a

    Joined:
    Jul 3, 2010
    #1
    I bought a 5s tonight and it has 7.0.3 installed on it. I downloaded 7.0.4 and I keep getting an error that says this firmware is not compatible.

    Do you guys think I should waste more time trouble shooting this issue or just go ahead and just jb 7.0.3 on my new phone?

    Exactly what bug fixes were done in 7.0.4? I notice the apple notes mentioned FaceTime bugs were fixed, but I don't even use FaceTime.
     
  2. paulbennett95 macrumors 6502a

    paulbennett95

    Joined:
    Aug 30, 2012
    Location:
    Long Island, NY
    #2
    Apple might have stopped signing 7.0.4 on the 5s since 7.0.5 was released, but I'm not sure.

    You could look up the changelog for iOS 7.0.4 to see what it fixed, probably not much.
     
  3. fizz7283 thread starter macrumors 6502a

    Joined:
    Jul 3, 2010
    #3
    I still get a notification when I plug it in saying there's an update for 7.0.4 though.
     
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    Make sure you're downloading the correct ipsw for your particular device
     
  5. fizz7283 thread starter macrumors 6502a

    Joined:
    Jul 3, 2010
    #5

    I had the correct one. I ended up going to a new computer and waiting several hours for it to download directly from iTunes and it worked. What a pain in the ass though.
     
  6. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #6
    What's the error it's giving you specifically?
     
  7. fizz7283 thread starter macrumors 6502a

    Joined:
    Jul 3, 2010
    #7
    It didn't give an error code, it just said "the phone could not be restored. this firmware is not compatible with this phone." Or something along those lines.
     

Share This Page