iOS 7.03 html app

Discussion in 'iOS 7' started by bslindgreen, Oct 27, 2013.

  1. bslindgreen macrumors newbie

    Joined:
    Jun 7, 2011
    #1
    Hi

    Ever since the 7.03 update to the iPhone, my html installed app hasn't been working. It worked perfectly on all models before, nut now, every time i click on a link in the app, it will open it in safari. How can i fix that bug?
     
  2. Daveoc64, Oct 28, 2013
    Last edited: Oct 28, 2013

    Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #2
    That's how it always worked until iOS 7.0

    The 2nd or 3rd beta of iOS 7.0 introduced the behaviour that you describe, which was inconsistent with how it's worked since the original iPhone (and therefore ended up breaking existing apps).

    Apple changed it back with iOS 7.0.3, as well as fixing some pretty major issues with web apps - some parts of JavaScript did not work at all in iOS 7.0, 7.0.1 and 7.0.2

    The feedback that developers got from Apple seemed to imply that these were all unintended changes, but that there were bigger issues to fix in iOS 7 before release.

    Rather than using links to move between pages, use JavaScript - that way the user will stay within the web app.
     

Share This Page