iOS 7.1 beta 1 & 2 - not compatible?!

TL24

macrumors 65816
Original poster
Oct 20, 2011
1,094
708
I've installed both iOS 7.1 beta 1 & 2 a week ago and not iTunes says my firmware is not compatible?! What gives?!

I should mention I was previously on iOS 7.1 beta 2 before downgrading to 7.0.4 to JB but the JB at the moment is too unstable and I do not see a reason to JB my phone anymore. With that said I've decided to re-install a fresh copy of 7.0.4 to re-install 7.1 beta 2 but as I've said before iTunes will not f'in let me....

Any suggestions??????? I'm on a iPhone 5 (GSM).
 

bkends35

macrumors 6502a
Feb 24, 2013
937
397
USA
Really strange. Are you sure you're on iTunes 11.1.3? Double check to make sure it's up to date. Only thing I could think of.
 

TL24

macrumors 65816
Original poster
Oct 20, 2011
1,094
708
Really strange. Are you sure you're on iTunes 11.1.3? Double check to make sure it's up to date. Only thing I could think of.
Yeah it's up to date, I tried about 10+ times and it finally worked?.... :confused:

----------

is your UDID registered?
Yessir it is, fully registered but as I just posted it finally worked and I was able to update to 7.1 beta 1 and then 2... I have no idea why it wasn't working previously...
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.