ios 7 App Update Bug

Discussion in 'iOS 7' started by CHMK, Sep 22, 2013.

  1. CHMK macrumors regular

    Sep 3, 2012
    Can anyone help? there were three 1.5gb updates in my app store, so i downloaded on computer and synced the updates.

    now the apps are still in the 'pending updates' section even though the button says open instead of updates. all other apps are in the correct time place, e.g. sept 21...

    how can i get them out of the pending updates section and into the september 22 update section?

    already tried reinstalling them on itunes...

    when i deleted them a cloud icon appeared next to it in the pending update section.
  2. CHMK thread starter macrumors regular

    Sep 3, 2012

    Attached Files:

  3. CHMK thread starter macrumors regular

    Sep 3, 2012
    I've also tried restarting my device, signing out of App Store and turning off automatic app updates to no avail
  4. Doell K. macrumors newbie

    Oct 13, 2011
    The same thing happened to me. I did a search for the app that was stuck & had to update it manually.
  5. C5Longhorn macrumors regular

    Jul 31, 2010
    I'm having the same issues with an app that says pending even though it has already been updated.

    I don't understand what you mean by manually update the app?

    Any suggestions on how to fix would be appreciated.

  6. ayeying macrumors 601


    Dec 5, 2007
    Yay Area, CA
    I had this issue too. I ended up deleting the app and reinstalling it. It fixed itself. Otherwise, it's just there and not really a bother either.
  7. C5Longhorn macrumors regular

    Jul 31, 2010
  8. TheIntruder macrumors 6502a


    Jul 2, 2008
    I'm having a similar issue with 7.04 and a single app that was updated (on the device) but is permanently stuck to the "Updated December, xx, 2013" list.

    I had also updated another apps, but those have gracefully cleared themselves from the list after the Open button is used.

    I've logged in/out of the App Store, deleted it from the device, only to see it come back once I reinstall from the computer. Deleted on the computer, redownloaded it, reinstalled it, and it appears again. Also restarted the device in combination with those other steps.

    The only way to not have it appear on the list is to not install the app.

    It's like the App Store app doesn't properly clear its log or plist.

    Kinda annoying.

Share This Page