iOS 7 Apps disappearing

Discussion in 'iOS 7' started by SgtP3pp3r, Nov 19, 2013.

  1. SgtP3pp3r, Nov 19, 2013
    Last edited: Nov 19, 2013

    SgtP3pp3r macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #1
    Has this happened to anyone else?

    I'm currently on iOS 7.0.3 on a brand spanking new iPad Air.

    Last night, I went into the Appstore and went on a free App rampage. I "bought" probably around 10 or 11 Free apps. I decided to leave the iPad downloading whilst I did a little browsing, however something weird started happening. As the smaller sized ones started finishing, I noticed that the App icon wouldn't become available. I noticed this first with one of them, and then realised that most of Apps were simply disappearing after they finished installing. The icon simply would vanish.

    I decided to let the download finish on the remaining apps before trying something, so I stopped using the iPad and let it download in peace. By the time the last one finished downloading, I noticed that NONE of the 11 apps I had downloaded were available. What's more, there seemed to be other apps that were missing. The one I noticed was the Facebook app.

    So i went into Settings>General>Usage to check out if the apps that i had downloaded were on the list and sure enough there they are, however, the name is not listed -just the icon.

    The app is there, and it's icon is present in the list but there is no name on it. This was true for all 11 Apps I had just downloaded as well as 3 other apps which were already on my iPad before this fiasco began.

    I dont understand why these 3 specific apps happened to have a problem. These were "Facebook", "Comics" (comixology) and "It's Playing". But i've tried deleting them, and reinstalling them, and I've also tried syncing back to my computer. I've also tried looking for them using spotlight, and had no luck. I'm at a work wifi connection now and it's horribly slow so I haven't been able to try downloading them directly to iTunes and installing them from there, or even upgrading to 7.0.4 however i've done a couple of google searches and it would seem i'm alone in this bug. I'm attaching screenshots of the app list in General>Settings>Usage where you can see the offending apps have an icon but no name.

    Anyone out there in macrumors land have any suggestions?


    -Edit-

    I've tried adding more Apps however nothing seems to be able to be added to the iPad. The apps show up as if they were installing however, when the install animation ends, the app simply vanishes! This is starting to worry me as returning this iPad will be an issue considering i'm not in the US.
     

    Attached Files:

  2. lelisa13p macrumors 68000

    lelisa13p

    Joined:
    Mar 6, 2009
    Location:
    Atlanta, GA USA
    #2
    Reset your iPad (hold down Power and Home buttons simultaneously, releasing both when you see the apple on the black screen.) You won't lose any data. Check for those apps again. Post your progress.
     
  3. burtelson1 macrumors newbie

    Joined:
    Nov 19, 2013
    #3
    Same identical thing happened to me today as well. Just out of the blue. Soft reset will not work.
     
  4. SgtP3pp3r thread starter macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #4
    Yeah, sorry to report that the soft reset didnt help much. It did help with a couple of them, 3 of the app icons came back, but the majority still is showing the same symptoms. Its odd that those three came back though.

    The ones that came back were "Garage Band", "google", and " comixology"

    I tried the soft reset twice more on the off chance that more apps would come back, but i've had no such luck. I had been trying soft resets all day and they hadnt worked up until now. Don't know what is diffrent now that it happened to work.

    I'm currently downloading the apps into itunes on my mac to see if i can sync them back to the ipad.
     
  5. SgtP3pp3r, Nov 19, 2013
    Last edited: Nov 19, 2013

    SgtP3pp3r thread starter macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #5
    were you installing apps when it happened?

    I'm thinking it might have been something with one of the updates I made before I started downloading all those apps. When I check back the chronology of updates and downloads, it looks like I had actually just updated "Facebook" and "It's Playing" before this whole thing went awry. Could be one of the apps i downloaded caused it, or maybe the update of one of these two.

    -edit-

    Also, and i might be reaching with this theory, but maybe this has to do with the fact that I restored this iPad from the backup of a jailbroken one. It seems that there is a limited amount of apps that I can "correctly" install on the iPad. When I go over this number the apps are not properly synced in. They sorta just poof out of existence once the install is completed. Maybe this is the "app install slot" or whatever where Cydia originally was in... I don't know. This is really starting to get annoying.
     
  6. lelisa13p macrumors 68000

    lelisa13p

    Joined:
    Mar 6, 2009
    Location:
    Atlanta, GA USA
    #6
    I wouldn't be surprised if the JB isn't screwing things up. It's not logical to use a JB backup to set up a brand new device. They don't play nice together.
     
  7. SgtP3pp3r thread starter macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #7
    I'll try restoring as new... It's just going to be so much work since I have two years worth of apps and documents that I need to make sure will have a backup before I can restore.

    I would not have thought previous iOS jailbreak to cause issues for iOS 7. I never had problems with this before, and I have done this with previous devices. I guess this is probably a vulnerability that did not get patched over, maybe in the right hands it could lead to a new jailbreak option.
     
  8. lelisa13p macrumors 68000

    lelisa13p

    Joined:
    Mar 6, 2009
    Location:
    Atlanta, GA USA
    #8
    If you had restored the JB iPad & removed the JB, then made the backup for use in setting up the new device, I wouldn't think it would matter. But if the backup is of the other iPad in JB status, that's problematic.
     
  9. SgtP3pp3r thread starter macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #9
    Alright,

    It seems that must've been the issue. Restore and update, then set up as new ipad. This seemed to have done the trick. Now to the gruesome job of getting everything back up to speed.

    Ugh.
     
  10. burtelson1, Nov 20, 2013
    Last edited: Nov 20, 2013

    burtelson1 macrumors newbie

    Joined:
    Nov 19, 2013
    #10
    THis was happening on my new iphone 5s. I was downloading an app and it would show the icon on the screen being downloaded but once it had finished it would just disappear. I would then go back to the app store at which point the app would say 'open' as if it were installed. I would tap it and nothing would happen. I then went to settings and usage and the app count would go up one like it was on the device. I would have to tap usage to see all apps on the phone and that's where the icon of the disappearing app would be but no data attached to it. I could delete that way from the phone. THis has still been an issue as of today. This is not a jailbroken phone either. I have reset and erased the phone and will try to backup from the cloud. Can't do it now because no Wi-Fi at work. I really don't want to start over as a new phone.
     
  11. SgtP3pp3r thread starter macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #11
    Like I posted earlier, this issue was resolved when I restored as a new iPad. I did a lot of tinkering before finally deciding to restore, and I tried repeatedly uninstalling apps and adding new ones.

    What seemed to be happening in my case was that the iPad could only have a maximum of 56 apps installed. Any app past this number would present the problem. It would also happen if I updated an app, and during the update process another app had finished downloading.

    One explanation for this behaviour might be the fact that the iPad air was restored from the backup of a Jailbroken device. I've done this process before, but it seems that for the specific jailbreak used in iOS 6, some of the effects still get carried over to iOS 7.

    However, this is just a theory as to where the problem came from. The fact is the problem, in my case, was resolved when I restored and updated iOS up to 7.0.4 . I restored the iPad as a new device, and manually reinstalled everything I needed.

    You have to be careful to backup your files within the specific apps you use. Unless they sync up to the cloud, you have to do this manually. So far, I don't think I lost anything, and the process was additionally helpful as I only reinstalled the apps that I actually use; eliminating a lot of unnecessary bloatware.
     
  12. Hussaineaz macrumors newbie

    Joined:
    Nov 25, 2013
    #12
    I'm having same issue on iPhone 5s

    App downloads, finishes then as soon as it completes, it's disappears! (It appears on my iPad though)

    Tried soft reset and erasing settings but still same problem.

    Is it an iOS issue??
     
  13. donnaw macrumors 65816

    Joined:
    Apr 19, 2011
    Location:
    Austin TX
    #13
    I had the same thing happen to me today on my Air. I had to do a full setup as new (for some reason I lost all sound in my games, no issues with Netflix, ESPN, TimeWarner or Amazon cloud player, they all were fine, it was just every game).

    Anyway I didn't restore because I didn't want to just put the same problem back. When I went to my purchased apps and downloaded them I was downloading 5-6 at a time. I only have 17 non-stock apps and three of them did the same thing. I was watching when they finished and the icon stayed dark and then just disappeared. Yes, I could see them in Settings.

    I did another full reset and started over. This time, no problems. Was a really, really weird day with my iPad. Not the type of thing I like to see on a new device.
     
  14. kboone6783 macrumors newbie

    Joined:
    Nov 5, 2009
    #14
    I have been having the same problem with every app that I have downloaded over the past week. I set up my 5S as a new phone this time around, so there's no chance that it is because of a restore from a jailbroken phone.

    Has anyone had any luck in getting these apps to work or become visible? I can see them all in the App Store as installed (it shows an "Open" button next to them) and they all have a preference pane that is functional in the Settings app, but they don't show up in Spotlight, aren't visible in Springboard and won't launch from the App Store "Open" button.

    I'd rather not restore my phone and set it up again. Does anyone have any suggestions or fixes?
     
  15. SgtP3pp3r thread starter macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #15
    I tried quite a number of fixes before finally caving in and doing a restore. What version iOS are you on? When the problem was occurring to me I was on 7.0.3 but after restoring as new phone wound up on 7.0.4. In my case, this fixed it.

    From the thread above you can see I had different theories, the one about it being caused by the previous jailbreak was just that, a theory. It might not even be the case.

    Point in fact, 7.0.3 was the version the iPad had installed when I got it, and the iPad did crash a lot at this point. The crashes have become a lot less frequent. It went down from having those crashes 2 or 3 times a day to only about once or twice in the whole two weeks since I upgraded.

    In my case, the iPad only admitted 56 apps installed. Any app above this number would end up vanishing. Same symptoms you described. You should check in Settings>General>Usage to see if these apps are listed on there. In my case, they were listed but only showed an icon, no name. If I erased apps until I got to 55 installed apps, what ever app was installed as 56 worked normally, but the app 57 would be a vanisher.

    It might not be the jailbreak that causes the problem, it might have been something else entirely. But at least in my case the "restore as new ipad" option fixed it.
     
  16. G.SHI macrumors newbie

    Joined:
    Dec 28, 2013
    #16
    I have the answer!!!

    I had the same problem on my iPhone 5S, simply go to settings>general>usage click on the app that was missing if it is there, click delete app... Then simply re-download it :)
     
  17. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #17
    An unregistered user sends in this tip, that usage restrictions may be involved.


    I had all the exact symptoms described in the article linked above. The article does not appear to mention the element that I found to be my cause of the problem. The night before I had upgraded my kids iPad to iOS 7 which installed 7.0.4 and later found 1Password to be acting as described to the letter. Today I realised that I had at one point changed my restriction to allow only apps under 12+. I wonder if this has happened to them as well either by intension or not. As soon as I had set Allow all Apps everything was set right.

    I noticed this when I deleted the app, again, using the usage list but instead of using iTunes to reinstall it I went to the iOS App store and noticed there was no link to download it. That's when I noticed it said 17+ and proverbial penny dropped. However, some have described the Open button not working For me if I set the restriction back down to 12+ the app store gives me no open button. This may not be their issue. But given the exact same symptoms I do wonder if perhaps a but resulting in a lowered allowed rating is the cause. Try changing, turn on and off the restrictions related to apps rating. Perhaps toting the entire restriction function as well. You never know.

    B
     
  18. Lex Yu macrumors member

    Joined:
    Nov 27, 2009
    #18
    JB is not the cause.

    I'm sure JailBreak is not the cause.

    I have the same issue with iPad 4(iOS 7.1), which has never been JB'd.

    And I agree that this issue has something to do with "updates."

    All the apps disappeared are the ones that updated recently.

    I have auto update feature ON with cellular network.

    BTW, have you changes your Apple ID(e-mail address)?

    Because, when I restored my iPad via iCloud, it asked me my old Apple ID (my old e-mail address).

    I tried the password for my current Apple ID but it didn't work and told me "could not restore apps purchased by that Apple ID and you have to restore those apps from your computer...." ... something like that.

    Maybe iOS 7 linked those Apps to the old Apple ID, and failed to verify qualification during automatic app-update. And this can be the reason why Apps disappeared.

    Just a theory.

    Pls let me know if it is the case, whether you changed your Apple ID or not.
     
  19. JasminBarby macrumors newbie

    Joined:
    Mar 25, 2014
    #19
    If the action of rebooting would not help, I can only think about restoring it. Never met such ridiculous problem, sorry.
     
  20. SgtP3pp3r thread starter macrumors member

    Joined:
    Mar 29, 2011
    Location:
    Honduras
    #20
    Nope, I haven't changed my apple ID since I got it with my very first iPod nearly 5 years ago.

    My iPad Air had never been jailbroken before either, what happened was I previously owned an iPad 2, which was jailbroken. However when setting up my iPad Air, I set it up from a backup of the iPad 2. The iPad 2 i factory reset and then sold. That's why i figured the jailbreak was to blame. Maybe it wasn't.

    Either way, what fixed the problem for me was restoring the iPad Air as a completely new iPad. I had to manually put everything back in (files, apps, photos, music, etc) but since most things were backed up in the cloud, this was not too hard to do.
     
  21. haruhiko macrumors 68040

    haruhiko

    Joined:
    Sep 29, 2009
    #21
    iOS 7.1 fixed this for me. No restoration was needed. I just updated OTA on the iPad itself and the disappeared apps came back.
     
  22. Lex Yu, Apr 1, 2014
    Last edited: Apr 1, 2014

    Lex Yu macrumors member

    Joined:
    Nov 27, 2009
    #22
    Unfortunately, I hit this issue while using 7.1.

    I think this issue is caused by a broken system file, catalog or something like that, and OS updates fixes the file.

    Those who having this issue on 7.1 may wait for 7.1.1 update. I thinks OS update renews those system files..

    PS: Maybe there is a tweak to force refresh those files. When my music library on iPhone was disrupted, I removed a certain file via iFunbox, the iPhone rebuilt the music library, and everything got OK. I think there should be something similar to Apps.

    PS2: BTW, I solved(?) this issue by restoring via iCloud. I had to move my media to my 128GB iPad, so it was not a pleasant experience.
     

Share This Page