General IOS 7 / evasi0n7 - JB app settings disappear after reboot

Discussion in 'Jailbreaks and iOS Hacks' started by YDH, Dec 24, 2013.

  1. YDH macrumors newbie

    Joined:
    Jan 23, 2012
    #1
    I have tested this on both an iPad 4 and iPhone 5. Basically after you jailbreak, install any JB program via Cydia that has a line item in settings. For example, we will use F.lux. F.lux has an app icon as well as an entry in settings. If you install F.lux, both the settings entry and the app will show. After a full reboot, the settings entry is gone, but the app remains still works. This goes for any JB app. If it has a settings section, it will disappear after a reboot, and even uninstalling and reinstalling the app won't restore the ability to change a JB app's settings. Can someone please verify this and help??
     
  2. Syndicate0017 macrumors 6502

    Joined:
    May 3, 2013
    #2
    Well documented. Wait for mobile substrate to be updated.
     
  3. YDH thread starter macrumors newbie

    Joined:
    Jan 23, 2012
    #3
    Got it; I knew MobileSubstrate needed an update still, but didn't realize the issues were related. Thanks.
     
  4. AppleFanatic10 macrumors 68030

    AppleFanatic10

    Joined:
    Nov 2, 2010
    Location:
    Encino, CA
    #4
    Same thing happened to me on my iPad Mini. I just re-jailbroke my iPad and it was fixed.
     
  5. Menneisyys2 macrumors 603

    Joined:
    Jun 7, 2011
    #5
    No need to re-JB - just reinstall MobileSubstrate from Cydia and respring.
     
  6. YDH thread starter macrumors newbie

    Joined:
    Jan 23, 2012
    #6
    Great workaround until it's updated, thanks!
     
  7. AppleFanatic10 macrumors 68030

    AppleFanatic10

    Joined:
    Nov 2, 2010
    Location:
    Encino, CA
    #7
    Thanks. At the time I couldn't do that because Cydia disappeared on my iPad Mini, therefore I couldn't access MobileSubstrate.
     

Share This Page