iPhone iOS 7 GM iPhone 4S no sound on lock and notifications

Discussion in 'iOS 7' started by Konner, Sep 14, 2013.

  1. Konner macrumors member

    Joined:
    Mar 20, 2012
    #1
    What do I do here? I traded my galaxy s III for the iPhone 4S because iOS 7 is beautiful as hell. But all of a sudden i dont have notification sounds or lock screen sounds. siri works fine, ringing works fine. but NONE of the notification sounds or lock sound will work. I'm so confused. Anyone else having the same problem?
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Do you have sounds turned on for different notifications in the settings for those notifications?

    As for lock sounds, assuming you have them enabled in settings, is it both lock and unlock, or just unlock? Unlock sound seems to have been removed recently, while lock is still there.

    Aside from that you can try restarting the phone to see if that might make a difference (if you haven't tried that already). Or, if none of that works, try resetting your settings to see of that might do the trick.
     
  3. Konner, Sep 14, 2013
    Last edited: Sep 15, 2013

    Konner thread starter macrumors member

    Joined:
    Mar 20, 2012
    #3
    I'm resetting all content and settings hopefully that'll fix it. I even restored the IPSW and still had problems

    EDIT: Still no notification sounds, nor keyboard sounds, NOR lock sounds (not unlock) but ringing, and siri works

    EDIT: set it up as a new phone, still problems.

    EDIT LAST TIME: Changed the dynamic wallpapers to stills and it started working. Okay apple im glad I'm just test driving an iPhone 4S and getting a nexus 5. atleast Android never gave me weird stupid problems like this.
     
  4. benji888 macrumors 65816

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #4
    Did you accidentally turn on Do Not Disturb mode with control center? ...I've done this, I'll be scrolling up and accidentally bring up control center, hit buttons before getting it back down.
     
  5. Konner thread starter macrumors member

    Joined:
    Mar 20, 2012
    #5
    I haven't. And it's actually happening again. No notification sounds.
     
  6. Konner, Sep 15, 2013
    Last edited: Sep 15, 2013

    Konner thread starter macrumors member

    Joined:
    Mar 20, 2012
    #6
    [​IMG]
    Heres a bump to show what its doing when i press the volume rocker buttons. It act like its not giving any sound, but my ringtone and game sounds work fine.

    EDIT: I unplugged the phone and sounds working now..
     
  7. Sirious macrumors 65816

    Sirious

    Joined:
    Jan 2, 2013
    Location:
    United Kingdom
    #7
    Settings; Sounds; "Change with Buttons" - turn that off.

    You're welcome ;)
     
  8. iPhil macrumors 68040

    iPhil

    #8
    OP: do you have "lock sounds" under Settings> sounds> first line under Airdrop > Off ?
     
  9. Konner thread starter macrumors member

    Joined:
    Mar 20, 2012
    #9
    iPhone 4S doesn't get airdrop.
     
  10. benji888 macrumors 65816

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #10
    hmmm, is your cable third party, or apple/3rd party getting old, maybe it's something with your cable?

    I know when I have bluetooth on in a car, or have it plugged in via USB, it takes over the audio....
     
  11. Konner thread starter macrumors member

    Joined:
    Mar 20, 2012
    #11
    It's a apple cable, and I have a apple wallplug. I traded over craigslist so I don't know how old it is, but he said perfect condition and it is not in perfect condition. I'm most likely going to jump to sprint and stop mooching off my parent's AT&T account, if I get my job tomorrow and preorder the iPhone 5C in blue.But even if I don't when I get my credit card I'm getting one.
     
  12. guyemtp macrumors newbie

    Joined:
    Sep 26, 2014
    #12
    Same problem

    My problem is very similar. I've gone thru all of the steps that have been posted. An additional symptom: If I add my cell number, the sounds turn off. If I remove my cell number (from iMessage & FaceTime) the sounds are back.

    All I can say is HELP please.
     
  13. guyemtp macrumors newbie

    Joined:
    Sep 26, 2014
    #13
    A Fix

    All of my sound issues were fixed by upgrading to 8.0.3:)
     

Share This Page