iOS 7 GM Safari Private Mode Bug?

Discussion in 'iOS 7' started by CthrewU, Sep 16, 2013.

  1. CthrewU macrumors member

    CthrewU

    Joined:
    Aug 11, 2010
    #1
    I'am a registerd dev and I have used the ios7 beta's and have yet to encounter this problem. When you put safari in private browsing mode there is a shadow that appears on the left side of the screen when the device is in landscape mode. The shadow immediately disappears as soon as you start to scroll the page or if you change the phones orientation. I haven't been able to find anything on the web about this bug and wanted to know if anyone running the GM can reproduce it. I've tried on two different iPhone 5's and the issue is present on both.
     

    Attached Files:

  2. Syndicate0017 macrumors 6502

    Joined:
    May 3, 2013
    #2
    Haven't had this problem at all on the GM. Maybe a stupid question but have you restored as new without restoring from any backup?
     
  3. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
  4. CthrewU thread starter macrumors member

    CthrewU

    Joined:
    Aug 11, 2010
    #4
    Tried restore and setup as new (didn't load anything on the device) and the grey bar still pops up occasionally. Usually when opening a link from a page in a new window.
     
  5. Syndicate0017 macrumors 6502

    Joined:
    May 3, 2013
    #5
    Messed around a little more and I got it to do it. It only did it on full websites (not mobile). You seem to have to open it in a new tab (while in landscape). If you open it in portrait and switch to landscape, no shadow.
     
  6. CthrewU thread starter macrumors member

    CthrewU

    Joined:
    Aug 11, 2010
    #6
    Yep! That's pretty much how it pops up for me.
     
  7. KeanosMagicHat macrumors 65816

    Joined:
    May 18, 2012
    #7
    Glad someone has finally confirmed this other than me.

    I'd mentioned it several times throughout the Beta process, describing it as a grey vertical bar to the left hand side.

    I was disappointed that it's made it all the way to GM.

    Private mode also still crashes now and again. It used to crash very frequently in Beta 6.
     

Share This Page