iOS 7 Install Issues

Discussion in 'iOS 7' started by efsad, Sep 20, 2013.

  1. efsad macrumors newbie

    Jun 5, 2011
    Hi All,
    I know-it's the hundred millionth iOS 7 install thread. Apologies in advance if this problem has been posted somewhere else, but Googling hasn't turned anything up.

    This morning I tried to download iOS 7 over-the-air on my iPhone 4S. I got an alert view saying I don't have enough space to download the update. This happened with 6.1.3 a while back, and to remedy the problem I connected to my MBP, let the computer download the update, and installed it. No problems.

    So this morning I connected to my computer with the USB cable that came with my phone and accepted the prompts to update. Agree to terms and conditions, transfer items, etc etc. Then I had progress bars in iTunes for "Backing up," "Waiting for iPhone," "Verifying update with Apple," "Waiting for iPhone" again. The Apple logo appeared (in iOS 7 style without the shine) with an empty progress bar on my phone.

    During the second "Waiting for iPhone" progress bar, I got an error on the computer (see attached) saying the following: "The iPhone '[My iPhone]' could not be updated. An unknown error occurred (-1)." My two options were "More Information," which took me here: and "OK" which stopped the process on iTunes only. The knowledge base article just said to try restoring two more times (no, I wasn't trying to restore, but that is the link I got from the error message). So everything in iTunes stopped. But the phone stayed on with the iOS 7 Apple logo and the empty progress bar. I waited a few minutes. Touched the screen. Held down the power button. Pressed the home button. Nothing happened. The phone just sat there with the Apple logo and empty progress bar.

    So I gulped and unplugged the phone. When I pressed the power button and got the dreaded recovery mode screen (it looks like this: So I plugged the phone in and iTunes cheerfully informed me that it had detected a device in recovery mode that had to be restored. Not intending to lose all my data, I downloaded RecBoot and pulled my iPhone out of recovery mode without restoring. The shiny, iOS 6 Apple logo appeared, my phone booted normally, and it was as if nothing had ever happened.

    Per the advice of the knowledge base article, I tried once more. Same result. Then I tried a third time. Same result. I started Googling, but it hasn't ever been jailbroken, I don't use Tiny Umbrella, and I don't have antivirus or firewalls. All the threads seemed to involve iPhones under at least some of these circumstances.

    I shut down my computer and booted into a partition I've always kept that runs SL 10.6.8 for cases like this. I updated iTunes, waited hours for the update to download again (even if I was using the same corrupt download every time on the normal partition, this was a fresh one, so that's probably not the issue), tried to update, and the exact same thing happened.

    Downloaded RecBoot onto my SL system, pulled my iPhone out of recovery mode once again, and booted into iOS 6.

    So now I turn to you. No historical problems with my iPhone (I saw some posts about hardware issues and water damage), no jailbreaking, nothing weird. I don't see why an issue affecting me wouldn't affect the 35% of iPhone users worldwide downloading iOS 7. Please let me know if you have suggestions. I'm still under warranty, but my desire to go into an Apple Store flooded with 5S and 5C seekers isn't that high...

    Thanks in advance for whatever assistance you can provide.

    Attached Files:

  2. Kabir8 macrumors regular

    Feb 3, 2010
    I would recommend trying Tiny Umbrella.
    I always forget how useful it can be to get me out of a jam.
    It's not that hard to navigate. Maybe give that a shot.
    Best of luck.
  3. efsad thread starter macrumors newbie

    Jun 5, 2011
    Hi Kabir8,
    Thanks for the quick response. I've downloaded TinyUmbrella from I've never heard of this before and I don't understand exactly what it's supposed to do, and thus how to use it.

    The FAQ says:
    "Q: What is TinyUmbrella?
    A: It does two things:
    Requests SHSH signatures for firmware restores
    Plays back those signatures enabling iTunes to continue the restore
    Q: What is an SHSH?
    A: An SHSH is a secure signature hash. Basically its a unique key. (To avoid a lengthy discussion)."

    Please forgive my ignorance, but I have no idea what this means or how I should use it. In addition, it mentions a lot of stuff about Cydia-I don't want to void my warranty by getting involved with Cydia/jailbreaking. (If it does involve that I suppose you could post anyway to help someone in this situation who's already jailbroken, but I would be curious if there was another way to go about fixing the problem).

    Could you please clarify how I/anyone in the future seeing this with the same issue should use Tiny Umbrella to clear this up?

    Thanks again.
  4. Eitel macrumors regular

    Sep 20, 2012
    Have you tried connecting the the USB cable on another port on the PC?
  5. efsad thread starter macrumors newbie

    Jun 5, 2011
  6. Kabir8 macrumors regular

    Feb 3, 2010
    I was stuck in a restore loop that wouldn't let me access my new 5S.
    I didn't void the warranty or jailbreak it, since that isn't even available for this phone and iOS yet.
    There is a specific option to exit the recovery loop if that -- enter recovery exit recovery or Fix recovery.

    Ignore everything else, try to fix the recovery or exit the recovery and try to fully reboot (home button plus power button until reset) and then try to sync again.
  7. Nolbertos macrumors newbie

    Feb 2, 2010
    Sorry to hijack this thread, but I started using tinyumbrella, and pressed Start Recovery and it got me outta the loop, so I take it now that I did that, should I retry to sync regularly with itunes to update to the newest IOS?? So far that's the steps I'm assuming. I'm keeping my fingers crossed that it works properly. My recovery was taking so long and I was getting frustrated. Thanks for providing this firmware

    Edit: My phone was a Iphone 4S taht was having that problem.
  8. efsad thread starter macrumors newbie

    Jun 5, 2011
    I just checked on TinyUmbrella and it said "In order for the 'Fix Recovery' button to be enabled you must put your device in DFU." My phone isn't in DFU mode-every time I try to do the update, it gets in Recovery Mode, then I pull it out using RecBoot, and it functions like a completely normal iOS 6 phone where I can use all my apps, etc.-no DFU. Are you saying I should try to update and then when it goes to recovery use TU Fix Recovery instead of RecBoot?

    Nolbertos, no problem about "hijacking the thread." :) Let us know how it turned out!

Share This Page