iOS 7 not choosing secondary SMTP

Discussion in 'iOS 7' started by iphonik4, Oct 2, 2013.

  1. iphonik4 macrumors newbie

    Joined:
    Aug 20, 2011
    #1
    Hi! I have encountered this issue on iPhone 5 (7.0.2), iPhone 5s (7.0.1) and iPad Mini (7.0). The problem is that I have 2 SMTP servers assigned to one of my mail accounts. When I am sending an email using the cellular data, the iPhone simply cannot connect to the primary SMTP server (which is ok, I understand why) so that I have another (secondary) SMTP server provided by my carrier which works well.. Now the problem is that when I am sending an email using the cellular data iPhone simply won't activate the secondary SMTP after unsuccessful attempt to connect to the primary one and won't send the emal. In order to send the email correctly, I have to turn manually turn off the primary server and then the device use the secondary one and everything works well.. Is that a bug in iOS 7? Does somebody have the the same problem?
     
  2. MTHoff macrumors newbie

    Joined:
    Oct 3, 2013
    #2
    Same problem

    I have iPhone 5, iPad 3, my wife has iPhone4s, iPad 2, all have same problem, IOS7 will not search past primary server. I tried Apple online chat, supervisor advised that did not know of problem, advised to delete account and set up new mail account. This did not solve problem. Apple need to sort this
     
  3. iphonik4, Oct 3, 2013
    Last edited: Oct 3, 2013

    iphonik4 thread starter macrumors newbie

    Joined:
    Aug 20, 2011
    #3
    iOS 7 not choosing secondary SMTP

    Yep! I suggest posting this issue on Apple's feedback site as a bug report :) hopefully they'll receice more of these reports and fix this soon :)

    Btw are all of your devices on iOS7?:)
     
  4. MTHoff macrumors newbie

    Joined:
    Oct 3, 2013
    #4
    Yep all ios7, same problem on all, discovered thus when away from home or office and sent mail via 3G, would not move to smtp of mobile provider. Kept repeating message that I could set up other smtp !!!!!
    I don't do Facebook so hopefully you can advise Apple there
     
  5. iphonik4 thread starter macrumors newbie

    Joined:
    Aug 20, 2011
    #5
    iOS 7 not choosing secondary SMTP

    Yep!!! I have the same problem!! Hmm I do not think that Apple has a Facebook. Please just open THIS site and send a bug report. I'll do the same. You do not need a facebook account for this:)
     
  6. MTHoff macrumors newbie

    Joined:
    Oct 3, 2013
    #6
    7.0.3 is rumored for this week, let's hope got fix !:)
     
  7. Tom359 macrumors regular

    Joined:
    Jul 13, 2007
    #7
    I found a fix on the Apple forums that works for me if you use Gmail:

    Ok, so I have a work around for this that I have tested on my iPad mini and iPhone 5s (both running ios7)..

    So what you'll have to do is disable the mail from the iCloud options.

    Go to the Mail App or (Add Account)
    You'll have to choose Other
    Name (Your choice)
    Email (Your @me or @icloud email)
    Password (Apple id Password)
    (Make sure it's IMAP)


    Incoming Mail Server
    Host Name (p02-imap.mail.me.com)
    User Name (@me or @icloud email)
    Password (Apple id Password)

    Outgoing Mail Server (Your choice... Mine being gmail)
    Host Name (smtp.gmail.com ....Gmail..in my case)
    Username (Gmail... in my case)
    Password (Gmail pw in my case )

    Push email works, and all mail now shows from my gmail account as it did before.
     
  8. newagemac macrumors 68020

    Joined:
    Mar 31, 2010
    #8
    The above settings won't give you push email from my testing in the past. You will get the email but it's just Fetch. Has this changed in iOS 7 or something?

    Also has anyone tested if 7.0.3 makes the secondary SMTP server work again with iCloud?
     
  9. iphonik4 thread starter macrumors newbie

    Joined:
    Aug 20, 2011
  10. kingdLo macrumors 6502

    Joined:
    Mar 20, 2009
    #10
    I thought about doing this but you do indeed end up losing push. Not that big of a deal but I want iCloud to be push and not imap.

    I really hope they fix this soon before I am forced to use iCloud imap
     
  11. mwalsh5757 macrumors newbie

    Joined:
    Sep 12, 2012
    #11
    Also having the same problem. Have a primary set that uses port 25 and then trying to do a secondary that uses port 26, since my user's ISP blocks port 25. It just sits there forever thinking about sending over the primary.

    Also having the REALLY, REALLY annoying problem of having changes in SMTP setting not working at first. Took over an hour yesterday of inputting the same settings over and over again (and, yes, they were correct); deleting the server numerous times; restarting the phone numerous times; turning the server of and on again multiple times; before it finally figured it was supposed to work and starting working.

    Didn't think to check what version of iOS is on the phones. Is there a chance this got fixed in 7.0.4?
     

Share This Page