iOS 8.1 and slow home WiFi

Discussion in 'iOS 8' started by RebornProphet, Oct 26, 2014.

  1. RebornProphet Suspended

    Nov 3, 2013
    I've reset network settings, changed modem and device settings to OpenDNS (, and still it's painfully slow. I've run speed tests on my line and there's no drop in our supplied speed.

    Anyone got any system tweaks/settings suggestions?

  2. davew41 macrumors member

    Jul 8, 2013
    Welcome to IOS, I have 5 android phones and 3 Iphones,
    the android phones load the internet based apps at least 50% quicker.. Facebok, twitter, web browser, etc..
  3. CaptMarvel macrumors 65816


    Sep 20, 2014
    North Carolina
    is your network security mode WEP or WPA2? maybe try switching to the opposite of the current setting? I was plagued by slow wifi when I first got my 6 Plus even on iOS 8 but after I switched everything was fast. Hope this helps.
  4. atiffarooq macrumors 6502


    May 27, 2006
    1. How far are you away from your router?
    2. Are you using 2.4GHz or 5GHz?
    3. Have you got other wireless devices that are operating faster at the same range as your iPhone?
    4. What is your subscribed speed, and what speed are you getting from a hard wired connection?
  5. RebornProphet thread starter Suspended

    Nov 3, 2013
    Been an iOS user since 1.0, I don't need "welcomed" to anything.


    I'm using Sky broadband in the UK and a lot of the modem settings are locked away even when you access the Admin panel. For example you can manually alter the DNS at the modem end, only the device.

    I'm currently using WPA2, but the only thing that's changed is my iPad is on iOS 8. My wife has an iPad 4 still on iOS 7.1.2 and running both side by side is ridiculous, her iPad loads web pages so much quicker than my Air.
  6. atiffarooq macrumors 6502


    May 27, 2006

    Apologies, I assumed you were using an iPhone! Is your Sky router running concurrently for both 2.4GHz and 5GHz? If so your wife's iPad may be using 5GHz hence the faster transmission, and you may be on 2.4GHz, which could be slow because of congestion. Have a look under the WiFi settings for both iPads to see if they're connected to the router in the same way.
  7. RebornProphet thread starter Suspended

    Nov 3, 2013
    I logged on and changed to WEP, no change in performance so put it back to WPA. I noticed that the channel was set to 6 and the "performance" tab was set to 54g Auto. I changed both of these to Auto and it has sped up tremendously.

    Long may it last.

    I couldn't see any mention anywhere in the modem settings for the GHz speed of the modem. Crap Sky Sagem modem.
  8. JohnnyGo macrumors 6502a

    Sep 9, 2009
    My suggestions:
    1) reset ALL settings
    2) did you update via iTunes or OTA ? If OTA try a restore

    If nothing works, make sure it is really a hardware or iOS issue by testing with other routers (at work or coffee shop) and by testing using other browsers on both iPads. It may relate to wifi settings in your router or specific settings in Safari (cached images make a lot of difference)
  9. atiffarooq macrumors 6502


    May 27, 2006
    Sky's modems do tend to be rubbish! If you get any more problems try change the channel to either 1 or 11 instead of 6, and leave the other setting on auto.
  10. Act3 macrumors 68000

    Sep 26, 2014
    side by side real time comparison of safari with 8.1 and 7.1.2, 7.1.2 even on an older device loads web pages considerably faster vs newer device running 8.1

    8.1 has a longer pause before displaying anything compared to 7.1.2
  11. RebornProphet thread starter Suspended

    Nov 3, 2013
    I've restored network settings, reset all other settings, restored in DFU mode and set up as new, and disabled wifi networking under Privacy.

    Some tinkering around with the channel and performance settings on the router admin panel seems to have done something positive for now. A lot quicker.


    Cheers mate.

    I'd say 80% of meaningful settings are locked away by Sky's software. Joke.
  12. JohnnyGo macrumors 6502a

    Sep 9, 2009
    I remember reading that different browsers use different strategies to display (faster or slower) the first bits of a webpage. Maybe that is the change you are noticing.

    Have you tried two downloads side-by-side ? Maybe it is a browser only issue as per my previous post.
  13. Sissyboy macrumors regular


    Jun 21, 2010
    Have you tested speed with Ookla speed test?

    You can also test your router speed with Wifi Sweetspots app,
  14. Capt T macrumors 6502a

    Mar 20, 2010
    When I first updated this morning safari was slooooow...I turned off wifi and turned it back on and the air, and it is running fine now. YMMV
  15. Damolee macrumors 6502

    Nov 20, 2012
    It is very slow.

    Example. Old Nexus 7 tablet. Same Wifi connection. 80mbit from same distance.

    iPad AIR is 30mbit tops, if I'm lucky.

    152mbit line.

    iPhone 6 is the same, slow in comparison to a HTC One M8.
  16. HolyGrail, Oct 26, 2014
    Last edited: Oct 26, 2014

    HolyGrail macrumors 6502


    Nov 21, 2010
    Planet Earth
    Saw this thread. Checked and saw slower speeds on my iphone 6 compared to my desktop.

    Decided to try 2.4GHz vs 5GHz

    Results: 2.4GHz





    Conclusion: Will be sticking with 5GHz. :cool:

    Headsup warning: some internet device (like some wifi printers) won't detect routers on 5GHz.

    I also just tried a comparison of my ipad 3 on 7.1.2 and my iphone on 8.1. Unlike what others have said so far, I'm getting the opposite then others. My iphone on 8.1 loads faster on mobile and desktop web pages compared to my ipad.
  17. twintin macrumors 6502

    Aug 10, 2012
    Have noticed that too. It seems, with each iOS iteration we are getting further and further away from "desktop" experience.

    This is however in my case a Safari issue and not a WiFi issue.

    I get around 80 mbps with my Air on the 5 GHz band.
  18. atiffarooq macrumors 6502


    May 27, 2006

    Just be wary that 5GHz has shorter range than 2.4GHz so you might want to switch to the latter when you are quite a distance away from your router, for better performance.
  19. MrGimper macrumors 603


    Sep 22, 2012
    Andover, UK

    To be able to switch between 2.4 and 5, your router would have to allow you to name the wireless networks presented by the 2 bands differently. Not sure sky/virgin etc allow you to do this. Apple Airport stuff does. If the 2.4 and 5 networks are named the same, your device will lock onto the best signal (in its head, but not necessarily correctly)
  20. atiffarooq macrumors 6502


    May 27, 2006

    I know the VM Superhubv2 allows you to name the two networks differently, not sure about Sky though.

Share This Page