iOS 8.1 Keeps asking for iCloud password

Discussion in 'iOS 8' started by Sam5281, Nov 5, 2014.

  1. Sam5281 macrumors regular

    Joined:
    Jun 4, 2014
    #1
    Now regretting doing this software update last night - because message keeps popping up requiring me to enter iCloud password. Not sure why, nothing has changed since the software I was running before. Its quite annoying, is this a bug? Or is there a fix? Hoping you guys can help out. Appreciate in advance!
     
  2. minimo3 macrumors 6502

    Joined:
    Oct 18, 2010
    #2
    This happened to me even on a brand new iPad which had never had any other version of iOS and which was set up as a new (not restored from backup). It seems like something in the initial setup process does not finish the iCloud setup. I was able to fix it by going to Settings -> iCloud and removing my account (which caused all my iCloud content to be deleted). Rebooting the device by holding down power+home until the apple logo appears, and then going back to settings->iCloud and re-entering my Apple ID (it will take a while to sync back all your photos/docs etc).
     
  3. DoctorKrabs macrumors 6502a

    DoctorKrabs

    Joined:
    Jul 12, 2013
    #3
    Check if Find my iPhone is off. It asks for the Apple ID when it's off, and it shouldn't when it's on.
     
  4. Alimar macrumors 6502a

    Alimar

    Joined:
    Sep 17, 2014
    Location:
    New York State
    #4
    That happened to me. It'll ask for it for iCloud, FaceTime, Apple Store, APP Store... and so on. And then, no more.
     
  5. TheIntruder macrumors 6502a

    TheIntruder

    Joined:
    Jul 2, 2008
    #5
    I've seen this pop up after each iOS 8 update.

    Settings will show that you're logged in to iCloud, but keep asking for the password, even after it is entered correctly.

    No need for drastic measures, just log out, and log back in.
     
  6. Sam5281 thread starter macrumors regular

    Joined:
    Jun 4, 2014
    #6
    I basically just went into general settings - and reset all my settings.

    Seems ok now
     

Share This Page