iOS 8.1 Performance on iPhone 6

yesjam

macrumors 6502
Original poster
Jun 6, 2014
253
1,104
Hi all, updated my iPhone 6 to iOS 8.1 about 6 hours ago, almost immediately after the download went live. iOS 8.1 slowed down my iPhone noticeably and I encountered a number of lags in animations and the like. For example, pulling down the keyboard produces a noticeable stutter. When Safari is in tab view there is noticeable aliasing on the rectangle that represents each tab.

What are your experiences with iOS 8.1, iPhone 6 users? I'm currently in the process of reverting back to 8.0.2, which ran flawlessly.
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,477
8,687
Ventura County
Hi all, updated my iPhone 6 to iOS 8.1 about 6 hours ago, almost immediately after the download went live. iOS 8.1 slowed down my iPhone noticeably and I encountered a number of lags in animations and the like. For example, pulling down the keyboard produces a noticeable stutter. When Safari is in tab view there is noticeable aliasing on the rectangle that represents each tab.

What are your experiences with iOS 8.1, iPhone 6 users? I'm currently in the process of reverting back to 8.0.2, which ran flawlessly.
Did you attempt a hard reset (holding both home and lock button or 10-15 seconds) before reverting back? 8.1 on my 6 is 10X better than 8.0.2 was and battery life is even better too.
 

2IS

macrumors 68030
Jan 9, 2011
2,936
427
6+ performance with 8.1 for me is the same as it was under 8.0.2 which wasn't all that great to begin with.
 

yesjam

macrumors 6502
Original poster
Jun 6, 2014
253
1,104
Did you attempt a hard reset (holding both home and lock button or 10-15 seconds) before reverting back? 8.1 on my 6 is 10X better than 8.0.2 was and battery life is even better too.
Yeah, I did, multiple times. I went back to 8.0.2 and it was back to running extremely well. Then I tried to redownload and reinstall 8.1; same issues. Hard reset three or four times, now reverting back to 8.0.2 for the second time.
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,477
8,687
Ventura County
Yeah, I did, multiple times. I went back to 8.0.2 and it was back to running extremely well. Then I tried to redownload and reinstall 8.1; same issues. Hard reset three or four times, now reverting back to 8.0.2 for the second time.
Very bizarre. Everything is extremely fluid on my device.
 

gardiboy

macrumors 6502a
Sep 30, 2011
577
40
I did an OTA update from 8.1 B2. Performance is fluid.

OP needs to do a hard reset.
 

Damolee

macrumors 6502
Nov 20, 2012
486
70
It could be the spotlight stuff indexing.

What it was for me. Try disabling most of the unused garbage for that in settings and reset, should speed it up.