iOS 8.1 - Wi-Fi calling not working

Discussion in 'iOS 8' started by April Knight, Sep 30, 2014.

  1. April Knight, Sep 30, 2014
    Last edited: Sep 30, 2014

    April Knight Suspended

    Joined:
    Jul 24, 2011
    Location:
    Olympia, WA
    #1
    Anybody else experiencing issues with iOS 8.1 Beta 1 and T-Mobile Wi-Fi calling not working? It worked flawlessly on the iOS 8 betas, iOS 8.0, and 8.0.2-- but ever since updating to iOS 8.1 beta 1, I'm not getting "T-Mobile Wi-Fi". Just "T-Mobile," and it's using the regular network to send SMS and do calls.

    Note: I thought it may have been due to SMS Forwarding being enabled, but I went ahead and disabled that and even restored my device as new, and Wi-Fi calling functionality is still not back. Odd thing is, if I go to Settings > FaceTime and try to turn on iPhone Cellular Calls, it does warn me that Wi-Fi calling is enabled and that it will be disabled if I turn on the cellular calls.
     
  2. Woochifer macrumors 6502a

    Joined:
    Apr 22, 2007
    #2
    Nope. Just made a call using wi-fi calling. The feature has worked for me since the first iOS 8 update.

    At this point, you might want to restore your device to factory settings, reinstall iOS 8, and see if wi-fi calling works at that point. If so, then try restoring your backup and see if anything changes. If you're still having trouble with wi-fi calling, then you might need to reset your network settings and go from there.

    Alternatively, you can reset the network settings first and see if that helps.
     
  3. April Knight thread starter Suspended

    Joined:
    Jul 24, 2011
    Location:
    Olympia, WA
    #3
    Thanks for the response! I am pretty well-versed in iOS, and have already restored as new as described in my OP, so I was mainly looking to see if anybody else was experiencing this issue. Thank you for the input though! If it's definitely working for you, I'll restore again and do some tinkering.

    Also, just to clarify: Your signature says you are using your iPhone 5s on iOS 8.0.2. I am talking specifically about the iOS 8.1 beta that just went out yesterday. I am also using an iPhone 6 Plus.
     
  4. Billymac19 macrumors regular

    Billymac19

    Joined:
    Apr 29, 2011
    Location:
    Phila, PA
    #4
    i have forwarding on and its working well....did u try the reset network as mentioned above?
    how about taking out out sim and putting back in?
    have you turned cell off(airplane mode, turn on wifi) and see if it connects too wifi calling that way?
     
  5. April Knight thread starter Suspended

    Joined:
    Jul 24, 2011
    Location:
    Olympia, WA
    #5
    Restored as new for a second time, and all is working now.
     
  6. Billymac19 macrumors regular

    Billymac19

    Joined:
    Apr 29, 2011
    Location:
    Phila, PA
    #6
    oh just an fyi, since I updated too 8.1 beta does drop off on occasion...never did that before...
     
  7. April Knight thread starter Suspended

    Joined:
    Jul 24, 2011
    Location:
    Olympia, WA
    #7
    Yeah, I'm noticing the same thing since my last post. It was working fine, but is occasionally randomly dropping off of Wi-Fi calling. Gonna report this.
     
  8. muadibe macrumors 6502

    Joined:
    Oct 11, 2010
    #8
    wi-fi calling iOS 8.02 on iPhone 6

    Not sure if this will work for anyone, but I saw mentioned on a forum somewhere that there was a potential fix.

    Since my phone was dropping calls when on wi-fi, I decided to give it a try last night. I haven't had any issues yet today.

    Steps.

    1 - connect iPhone to iTunes.
    2 - select the phone in iTunes, then in the 'Options' section at the bottom of the main panel, select 'Allow wi-fi syncing' on the phone.
    3 - click 'Apply'.

    There were a few apps that synced over which I deleted, but I'm not getting dropped calls.
     
  9. winterny macrumors 6502

    Joined:
    Jul 5, 2010
    #9
    I've had this happen a few times, and "Reset Network Settings" brought it back to life. Definately seems like a bug, and hopefully it gets fixed soon.

    I had the same issue in 8.0 and 8.0.2

    Please report it on bugreporter.apple.com
     

Share This Page