iOS 8.3 and wifi broken again

Discussion in 'iOS 8' started by jmmo20, Apr 9, 2015.

  1. jmmo20 macrumors 65816

    Joined:
    Jun 15, 2006
    #1
    So I'm quite tired of iOS development cycles.
    Every now and then they decide to change the behaviour of wifi connections. All throughout iOS 7 wifi would disconnect itself after a little while whenever the phone was locked. Only data connection was cellular. That was ok for everyone except people like me with no cellular signal at all at work.

    I rely on wifi for connectivity while at work. So with iOS 7 this would always happen. I had to leave a radio player running in the background all the time to avoid the iPhone to drop the wifi connection.

    With iOS 8 this was "fixed" and iOS kept wifi connections alive. I could get emails, messages, and calls no problem. And iOS 8.3 "broke" it again.

    Why this inconsistency? Why not add a damn toggle to "keep wifi connection alive" for goodness sake.
     
  2. ionjohn macrumors 65816

    ionjohn

    Joined:
    Jun 5, 2013
    Location:
    Canada
    #2
    Never happened to me and i've had every iphone with every update

    Weird uh?
     
  3. jmmo20 thread starter macrumors 65816

    Joined:
    Jun 15, 2006
    #3


    it's easy to miss if a) you have cell signal and b) you aren't using push

    I use a SIP app that forwards my office calls to my phone over the wifi network. When wifi is not kept alive, I miss all the calls until I happen to wake the phone up, at which point i receive all emails and notifications at once.

    This has happened with all my phones, 4S, 5, 6, and it happens to everyone in my company.
     
  4. adamhenry macrumors 65816

    adamhenry

    Joined:
    Jan 1, 2015
    Location:
    On the Beach
    #4
    I turn off cell data and use wifi only when at home and emails pop in 1 at a time all day long.
     
  5. FloridaGary macrumors regular

    Joined:
    Oct 18, 2014
    #5
    Sorry to hear about your wifi issue. I've never experienced it with my 4. 5 or 6
     
  6. Yun0, Apr 9, 2015
    Last edited: Apr 9, 2015

    Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #6
    never had any wifi problems on any iphone from 3gs -> 6 skipping the 5s, on dir-825 b1, wndr3700 v1, wndr4300 & tl-wdr4900 v1.3 routers all with ddwrt. the minimal times i used stock fw also appeared fine..both 2.4ghz & 5ghz bands

    the device dropping wifi connection when idle & locked when battery is low like around 15-10% or lower is normal, its doing it to save power as that only happens when battery is in the red
     
  7. Eckscaliber macrumors 6502a

    Eckscaliber

    Joined:
    May 30, 2012
    #7
    Since 8.3 broke yours, maybe it will fix mine. I've been having the same issue since around 8.1.
     
  8. I7guy, Apr 9, 2015
    Last edited: Apr 10, 2015

    I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
  9. sanke1 macrumors 65816

    sanke1

    Joined:
    Nov 9, 2010
    #9
    Have you tried to determine if your WiFi router is working as it should? It may be a compatibility issue (most common problem). Can we ask you to try using a different router at workplace and test if WiFI still drops?

    I have never encountered this problem on 5 different iPhones and 3 iPads I have used in my life on iOS 7 & 8.
     
  10. jmmo20 thread starter macrumors 65816

    Joined:
    Jun 15, 2006
    #10


    it happens with any wifi. this is a corporate wifi station, and they are actually 10 or 15 stations all throughout the building. It worked fine before upgrading, it went back to the "not persistant wifi" behaviour right after I upgraded.

    I participated in a thread when ios 7 back when it was out regarding this very same issue. They fixed it with ios8, and now broke it again with 8.3.

    ----------

    once again, you probably just don't notice that your wifi drops, because you have cellular data, and maybe your home wifi connects faster because it doesn't require authentication.

    But yet again, no blame on the wifi network, as it worked fine before updating 8.3 and everything broke after 8.3

    ----------

    http://forums.macrumors.com/showthread.php?t=1634110
     
  11. AllieNeko macrumors 6502a

    Joined:
    Sep 25, 2003
    #11
    Thus has always been the behaviour of iOS if not plugged in to a charger. If you want to use an application like that you need Android, unfortunately.
     
  12. adamhenry macrumors 65816

    adamhenry

    Joined:
    Jan 1, 2015
    Location:
    On the Beach
    #12
    My 5s is running 8.3 and maintains a connection to my WPA2 secured wifi continuously while disconnected from the charger. I have cellular data disabled and receive email throughout the day.
     
  13. jmmo20 thread starter macrumors 65816

    Joined:
    Jun 15, 2006
    #13
    it goes back and forth. officially they have never said it should work like this or not. So one of either behaviours is a bug and keeps coming back and fixed or broken again.

    how hard is it to add a "persistant wifi" (Warning!! uses more battery) toggle somewhere, for gods sake.
     
  14. AllieNeko macrumors 6502a

    Joined:
    Sep 25, 2003
    #14
    Interesting, my iPhone has ALWAYS disconnected from Wi-Fi when the screen is off unless plugged in. And I agree, it's stupid there hasn't been a toggle...
     
  15. PinkyMacGodess macrumors 68040

    PinkyMacGodess

    Joined:
    Mar 7, 2007
    Location:
    Midwest America.
    #15
    Yesterday, I was unable to connect to the wifi at a place where I have always been able to connect. The last few times I've been there, the wifi has auto connected, and yet, yesterday, no. Tried to connect manually, and could not get a router, or DNS server address. No joy...

    This is the first time, post 8.3, that I have been there. I hope this doesn't start a trend.

    Neither my 6+ or my iPad 4 would connect. BOTH were off the net... I felt so alone, and frustrated. I tried a reboot of the iPad, and still nothing. Oh, and their cell signal is pathetic at best.
     

Share This Page