iOS 8.4 Beta and T-Mobile Roaming

Discussion in 'iOS 8' started by KJmoon117, Jun 3, 2015.

  1. KJmoon117 macrumors 6502a

    Joined:
    Jun 10, 2007
    Location:
    NC
    #1
    This is an extremely niche issue but I just landed in Japan, unable to connect to any network. I called T-Mobile using Wifi calling through the airport's wifi network and they had me send over diagnostics.

    Well they informed me that my latest iOS check was failing and that was the cause for me not being able to roam internationally on an iPhone 6.

    Has anyone else ever noticed this issue? If not, I suppose this is a PSA for those on a beta OS looking to travel abroad.
     
  2. david91 macrumors regular

    Joined:
    Apr 15, 2015
    #2
    it happens when your new area does not have sufficient capacity for roaming function as compared to your original network provider.
     
  3. KJmoon117 thread starter macrumors 6502a

    Joined:
    Jun 10, 2007
    Location:
    NC
    #3
    Not sure about that since T-Mobile states that I should have coverage everywhere in Japan and South Korea. It seems like other people using iPhones end up connecting to SoftBank/NTT the moment they land but I haven't got reception all day despite resetting network settings, manually selecting carriers, etc.
     
  4. moloukhya macrumors regular

    Joined:
    Apr 6, 2007
    #4
    I've been on iOS 8.4 beta and have been able to roam internationally on T-Mobile on 2 trips to Canada. The first of which on beta 2, after a few days my phone said it needed to be activated, and I had to connect to wifi to complete the activation process (several times throughout the day, an odd bug). The second trip was on beta 3, and performed as usual.
     
  5. KJmoon117 thread starter macrumors 6502a

    Joined:
    Jun 10, 2007
    Location:
    NC
    #5
    Yeah I doubled check with T-Mobile this morning and failed to update the thread.

    It turns out that they disabled my international roaming for some reason and after turning that back on it worked fine.
     

Share This Page