iPhone iOS 8 duplicate music

Discussion in 'iOS 8' started by povilasjuska, Sep 23, 2014.

  1. povilasjuska macrumors newbie

    Joined:
    Sep 23, 2014
    #1
    After updating to iOS 8 about half my music library now has song duplicates. The songs are in grey font. When you press on them the song doesn't play but a random one starts playing instead. If you press the stop button, nothing happens either.
    There is a screenshot in the attachment.

    Also, every time I plug in my iphone to my mac, it syncs about 250 songs, which are ALREADY on my iphone, what's up with that?

    Anyone have any idea how to remove these useless duplicates and what's up with all the syncing?

    Cheers.
     

    Attached Files:

  2. J Michael T macrumors member

    Joined:
    Sep 8, 2010
    #2
    Me too

    I'm experiencing the same issue throughout my iPhone 5s music library. Unfortunately I did not notice until I left on a business trip so I haven't had a chance to re-sync the phone and see what happens. It is very bizarre.
     
  3. povilasjuska thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #3
    more

    I also tried re-syncing: erasing all music and syncing again. The songs, which were duplicated have stayed in the Music library as the grey duplicates even though they were not selected to sync into my iPhone...
     
  4. povilasjuska thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #4
    solution

    Found it: you need to turn off the function, which shows music stored on iCloud. Settings ->Music ->Show album music.
     
  5. thelnnovator macrumors newbie

    Joined:
    Sep 15, 2014
    #5
    this isn't a great solution as it turns off any songs that have in the cloud that aren't duplicates
     
  6. povilasjuska thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #6
    well

    Well it works for me as I have no songs stored on my cloud. But if anyone comes up with a better solution, let us know :)
     
  7. *~Kim~* macrumors 6502

    Joined:
    May 6, 2013
    Location:
    UK
    #7
    The grey is because the show all music setting is enabled I think.
     

Share This Page