iPhone iOS 8 how to change iMessage/Facetime activation number?

Discussion in 'Jailbreaks and iOS Hacks' started by xxbluedragonxx, Oct 13, 2014.

  1. xxbluedragonxx macrumors newbie

    Joined:
    Oct 13, 2014
    #1
    I am having a problem with my iPhone4S in that it keeps trying to send an international text to one or two numbers abroad. I am convinced the numbers are related to iMessage or Facetime activation.

    This happens even after a factory reset, hard reset, full erase/reset and happened after I did a recovery mode reinstall of iOS8 (file downloaded from Apple.com)

    So therefore the number is somewhere in the carrier settings.

    Can anyone please show me step by step how I can search for and replace/change this particular number?

    I am new to iPhones and jailbreaking them (previously from Android where I was quite comfortable with jailbreaks and flash/reflash firmware, editing product codes etc to get appropriate firmware installed) so although am technically competent am not familiar with iPhone system internal files and what needs to be done to edit where.

    Hope someone can help!
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    It always does that in order to activate facetime and imessage.
    You cannot change the number it contacts to activate , its done internally without you even knowing or be able to edit it.
     
  3. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    Even if you could do what AJ says you cannot, you could not do it right now. There is currently no iOS 8 jailbreak. No jailbreak, no file system level access.
     
  4. xxbluedragonxx thread starter macrumors newbie

    Joined:
    Oct 13, 2014
    #4
    I read somewhere it was possible to edit the default APN settings at some low level file so hence thought it might be possible to do this for the activation number.

    Sadly if this is not the case I have to return the phone. I asked my carrier to try to block it but they can't block outgoing international texts so the phone is secretly trying to send texts to this international number and pushing my bill up :(

    Thankfully carrier have refunded me but this can't be an ongoing arrangement and if I can't edit the number in any way have no choice but to send the handset back. Oh well, it was nice while it lasted!
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    It's not that the phone keeps sending out International texts, it's that unofficial carriers interpret the iMessage/FaceTime activation codes as a text to an International number.

    You can turn off iMessage and FaceTime to stop the activation codes being sent out or switch to an official carrier. Short of those, there is no solution.
     
  6. xxbluedragonxx thread starter macrumors newbie

    Joined:
    Oct 13, 2014
    #6
    I did try turning those off and also put in Restriction for Facetime but still the "texts" or whatever they are still showed up in my bill. I've contacted the seller and going to return the phone as there seems to be no solution to this and I will keep getting billed for them otherwise :(
     
  7. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #7
    Have you tried restoring the phone and turning off iMessage/Facetime during the activation process ?

    Also, uncheck all the contact sources (email and phone #)
     

Share This Page