iPad iOS 8: Safari's bookmarks side bar doesn't automatically go away

drenline

macrumors 6502a
Original poster
Aug 8, 2010
749
9
When I hold my iPad Air in landscape mode, I click on the 'bookmarks' button, and now a side bar comes out. But when I click on any specific bookmark, the side bar still remains there but the page is now viewed in the smaller window.

WHY APPLE?? Why would you do this?? Is there a fix to make the side bar disappear as soon as I click on a bookmark, and return to the iOS 7 (and older) version? This is so annoying...I would manually have to re-click on the bookmarks button to make it go away.
 

EdgardasB

macrumors 6502a
Apr 14, 2014
618
80
Lithuania
For me it is ok if I want to open a lot of websites fastly. If you are annoyed, then access your bookmarks by pressing at the url...
 

Breezygirl

macrumors 6502a
Oct 7, 2011
644
463
My biggest peeve too, extra added annoying steps to do simple things. There was no point to add them. But then I haven't liked Safari since IOS7 was introduced.

I can't find any way to automatically remove the bookmarks sidebar. Grrr!
 

Stuke00

macrumors 68000
Oct 11, 2011
1,674
74
Collinsville,IL
When I hold my iPad Air in landscape mode, I click on the 'bookmarks' button, and now a side bar comes out. But when I click on any specific bookmark, the side bar still remains there but the page is now viewed in the smaller window.

WHY APPLE?? Why would you do this?? Is there a fix to make the side bar disappear as soon as I click on a bookmark, and return to the iOS 7 (and older) version? This is so annoying...I would manually have to re-click on the bookmarks button to make it go away.
Sounds like a bug. I click bookmarks button on my iPad in landscape, then click a bookmark. Side bar goes away.

EDIT: It only did that the one time. I cannot get it to go away after trying it a second time.
 

Bigbadduke

macrumors newbie
Sep 18, 2014
4
0
I've discovered this works like normal in portrait mode. Landscape is the problem. I sure hope this is a bug and not a "feature". What the hell were they thinking? This is NOT progress Apple!!!!
 

drenline

macrumors 6502a
Original poster
Aug 8, 2010
749
9
Decided to move all of my bookmarks over to the Favorites bar as a temporary solution. Works like it should now...take that, Apple!!!
 

Stealth Beige

macrumors newbie
Sep 18, 2014
4
2
When I hold my iPad Air in landscape mode, I click on the 'bookmarks' button, and now a side bar comes out. But when I click on any specific bookmark, the side bar still remains there but the page is now viewed in the smaller window.

WHY APPLE?? Why would you do this?? Is there a fix to make the side bar disappear as soon as I click on a bookmark, and return to the iOS 7 (and older) version? This is so annoying...I would manually have to re-click on the bookmarks button to make it go away.
This is also driving me nuts as well. It disappears nicely in portrait mode, but I don't want to use portrait mode on the couch. Definitely a step backwards.
 
  • Like
Reactions: jbachandouris

mangomind

macrumors 6502a
Mar 15, 2012
541
3
I think it's more consistent now. Now Safari joins apps like Notes and Mail that hide the sidebar in portrait mode and show it in landscape mode.
 

tim821

macrumors newbie
Feb 3, 2008
5
0
Bookmarks Sidebar persists in landscape view

I agree the GUI is now more consistent but worse. This simply is not an improvement in my browsing experience. Apple must do focus group analysis of its "upgrades" I just wonder who is in the focus group. There should be an option to defeat this action.:mad:
 

Joesazhome

macrumors newbie
Aug 23, 2015
1
0
When I hold my iPad Air in landscape mode, I click on the 'bookmarks' button, and now a side bar comes out. But when I click on any specific bookmark, the side bar still remains there but the page is now viewed in the smaller window.

WHY APPLE?? Why would you do this?? Is there a fix to make the side bar disappear as soon as I click on a bookmark, and return to the iOS 7 (and older) version? This is so annoying...I would manually have to re-click on the bookmarks button to make it go away.
Figured it out!!!

Just click on the open "book" at the upper left hand corner of the screen. This will either open or close the bookmarks/favorites tab/thingy
 

drenline

macrumors 6502a
Original poster
Aug 8, 2010
749
9
Figured it out!!!

Just click on the open "book" at the upper left hand corner of the screen. This will either open or close the bookmarks/favorites tab/thingy
it still doesn't automatically go away when I click on a bookmark, that was what my post was referring to. It used to automatically disappear as soon as I click on a bookmark, not manually have to do it myself.
 

BigBooDaddy

macrumors newbie
Apr 9, 2017
1
0
it still doesn't automatically go away when I click on a bookmark, that was what my post was referring to. It used to automatically disappear as soon as I click on a bookmark, not manually have to do it myself.
Click on upper open book radio button, highlited in blue and that will make sidebar go away.
 

Attachments

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.