iOS 8 won't connect to exchange

Discussion in 'iOS 8' started by AlwaysHopeful, Sep 17, 2014.

  1. AlwaysHopeful macrumors member

    Joined:
    Aug 21, 2007
    #1
    Hi Guys,

    Just updated to iOS 8 on my iPhone 5S and now it won't get new mail or send mail via my work exchange account.

    I have modified my iPhones exchange settings to try and have it reverify (by making them wrong and then right again).

    Both with the wrong and right settings I get the verification ticks!!

    The phone believes it is connecting with exchange (I get "Updated Now" messages in the Mail app) but my mail message won't work.

    My iOS 7 ipad syncs properly still as does my macbook Air.

    Anyone else having issues? Have searched around but can't see any other complaints.

    Thanks.
     
  2. JoeTomasone macrumors 6502

    Joined:
    Aug 8, 2014
  3. Sveke macrumors newbie

    Joined:
    Aug 24, 2014
  4. aidenh37 macrumors regular

    Joined:
    Apr 9, 2014
    Location:
    Canberra, Australia
    #4
    Try a restore

    Back up your data in iTunes and restore. Put the backup back on and all should be fine. Restoring fixes everything and is sorta fun.
     
  5. AlwaysHopeful thread starter macrumors member

    Joined:
    Aug 21, 2007
    #5
    Thanks

    Thanks guys,

    I've rebooted and all that Jazz.

    I'll take off exchange and reload it and see if that sorts it.
     
  6. AlwaysHopeful thread starter macrumors member

    Joined:
    Aug 21, 2007
    #6
    It's trying now, but real slow

    It has started to get mail - It gets the headers and lists the new mail.

    But it won't download the bodies! Just keeps saying "downloading"!

    Arghh

    Not tried the restore idea as yet - worried it might take ages.
     
  7. Nmirro macrumors newbie

    Joined:
    Sep 17, 2014
    #7
    Having the same issues. iOS 8 on both my phone and iPad are not syncing email. I either get the first 3 days of my prior 2 weeks or all the email "clear out" and the mail program continuously downloads emails... Probably hammering our server. Gmail seems to work fine.

    I have tried deleting exchange profile and all that did was prevent my calendar from syncing on my iPad.
     
  8. AlwaysHopeful thread starter macrumors member

    Joined:
    Aug 21, 2007
    #8
    Yup it says it is just downloading all the time.

    I have some mail from a week or so ago that's unread :eek: and it came up on the lock screen as a new email. Same old date and time.

    I have left it for now - I think it is just relentlessly going through my entire large mailbox re-getting stuff it already has :mad:
     
  9. AlwaysHopeful thread starter macrumors member

    Joined:
    Aug 21, 2007
    #9
    Okay, so after about an hour and a half it seems to now have re-downloaded all my - already there - emails. Bit bizarre but it has settled down now and seems to be working.

    Moral is don't have such a large inbox!

    Thanks for help guys, knowing it was working for you was a great help.
     
  10. beavertime macrumors newbie

    Joined:
    Sep 19, 2014
    #10
    Same problem

    Works on iPad 3 with iOS8 (was previously working on this device in iOS5, 6, 7 too). But it doesn't work on new iPhone 6. Any suggestions would be helpful. (Turning off wifi didn't make a difference)
     
  11. WDavis00 macrumors newbie

    Joined:
    Sep 20, 2014
    #11
    iOS 8 won't connect to Exchange

    I am having the same issue. Upgraded to a shinny new iPhone 6 plus and now exchange email doesn't work, I get the same verification ticks but no mail folders no new mail no nothing. Did a restore to start with and get the full mailbox but nothing new comes in. It doesn't appear to be talking at all. My iPad Air is still just fine all are running iOS 8 and only the iPhone 6 plus is having issues. The automatic reply setting shows loading... And never comes back. It appears that the verification check doesn't work and the profile never actually gets fully set up. Inbox shows but no sub folders or mail. Default mail and calendar do not have the exchange options showing, etc.
     
  12. Fwny macrumors newbie

    Joined:
    Sep 20, 2014
    #12
    Having the same issue here. It is definitely an iOS 8 issue that isn't specific to the new iPhone. I first had trouble setting up Exchange on my new iPhone 6 but had it working on my iPad that also had iOS 8 on it but the mail config was restored from a backup.

    I wiped my iPad to factory and tried to set up my Exchange account from scratch and now I can't get it running on my iPad either.

    I have a Google Apps account so I should still have ActiveSync access. (I know they took it away from regular Gmail accounts)
     
  13. scrateef, Sep 20, 2014
    Last edited: Sep 20, 2014

    scrateef macrumors newbie

    Joined:
    Sep 22, 2008
    #13
    IOS 8/iPhone 6 not working with Exchange

    Hello, all:

    I was having the issues described in this thread with getting my Exchange server to work on the iPhone 6/IOS 8. Nothing would make it work (even though I got the check marks when verifying my login credentials). Giving up temporarily, I got out my laptop to check mail. Once I logged in, I found this message:

    Subject: Error with your new mobile phone partnership

    You have 10 phone partnerships out of the maximum allowed 10 partnerships. After you reach the maximum, you can't create additional partnerships until you delete existing ones from your account. To do so, sign in to Outlook Web App, click Options > Phone > Mobile Phones, and delete any unused partnerships.



    I followed the instructions and saw that, yes, I had 10 iPhones/iPads listed in my account, ordered by last sync date.
    (note: I had to click 'Options' and then 'See All Options' to get to the 'Phone' menu).
    I deleted all the old devices from the list and then set up the Exchange account from my phone. The check boxes appeared again, and after about 1 minute, all my messages and folders were loaded on the phone.

    Perhaps some of the users experiencing these issues also have a bunch of current/old devices synced with their Exchange accounts.

    Good luck!

    -B
     
  14. JoeTomasone macrumors 6502

    Joined:
    Aug 8, 2014
    #14
    I had no problem with iOS 8 on my iPad and 5s, and no problems with the 6 yesterday, restored from the 5s's backup. Getting my email both from the Mail app and from Cloudmagic Mail app.
     
  15. bgro macrumors 6502a

    Joined:
    Jul 6, 2010
    Location:
    South Florida
    #15
    Having the same issue. Upgraded to a 6 Plus and set up the phone as "new" as I do every year for spring cleaning. I am 100% positive that all my settings are correct yet none of my folders are showing except for the inbox and there are no emails on my inbox.
     
  16. RobQuads, Sep 20, 2014
    Last edited: Sep 20, 2014

    RobQuads macrumors regular

    Joined:
    Jul 11, 2010
    #16
    I'm having the same problem. My old iPhone5 on iOS8 is working fine. My iPhone6 is not syncing.

    I restored my iPhone6 from my iPhone5 backup but have since also tries deleting and re-adding my exchange account but its still not working.

    EDIT: Looks like my work exchange is working, its just google thats not.

    EDIT2: Looks like its the Google Free apps problem where they have removed exchange access for new devices.
     
  17. JoeTomasone macrumors 6502

    Joined:
    Aug 8, 2014
    #17
    Edit your Exchange account and re-enter the password. Do you get all check marks when you save it?

    I'd say to ask your Exchange admin about it, but it's Saturday. :)

    If you have a Mac and Xcode, perhaps there are some console messages that might be helpful?
     
  18. bgro macrumors 6502a

    Joined:
    Jul 6, 2010
    Location:
    South Florida
    #18
    This was actually this issue for me as well. I logged into the Outlook web email for my company and sure enough I had an email telling me that I had too many mobile partnerships. I deleted all the old ones that I had, reset up the mail on my phone and after about 30 seconds, all my mail and folders appeared. Thanks for the help!
     
  19. WDavis00 macrumors newbie

    Joined:
    Sep 20, 2014
    #19
    Worked for me

    I went to the OWA site for my Exchange email and, sure enough, I was at my maximum of 10. I had phones from way back on there. Now I have only my iPad and my shinny new iPhone 6 plus. :) there may be others here with another issue but this was mine. I didn't even have to delete and re add by Exchange profile, it just started working as soon as there was a slot on the device list.
     
  20. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #20
    Working for me too, exchange 2013 connecting with a 5c.
     
  21. BruceForrester macrumors newbie

    Joined:
    Sep 20, 2014
    #21
    I also can't connect to our exchange, after the upgrade on both my iPhone or iPad. What I do notice is under the exchange account, at the bottom it says "Automatic Reply" "Loading" It is grayed out and looks stuck. :(
     
  22. egraphixstudios macrumors 6502

    egraphixstudios

    Joined:
    Dec 28, 2007
    #22
    6+ exchagne 2013- not working. sits there loading- but nothing happening...

    another exchange 2010 account also not working...

    IOS8- itis very buggy...
     
  23. Dkitchen89 macrumors newbie

    Joined:
    Sep 20, 2014
    #23
    I also have the same issue with exchange 2013.

    Connects to exchange but keeps continually re downloading my emails.

    Had to downgrade to iOS 7 again as it was unusable, doesn't seem to be a solution to this issue!
     
  24. fahmad42 macrumors newbie

    Joined:
    Sep 20, 2014
    #24
    iPhone 6 won't sync with exchange

    I have had the same issue getting my iPhone 6 to connect to my work exchange account. I also had the same error email saying I had reached my maximum 10 accounts, so I deleted everything but my iPad from the list (still on iOS7). I deleted and added Exchange back to my iPhone 6, and while I get all check marks when I enter the info, it still downloads nothing. When I try to send an email to test it, it doesn't send.

    Any thoughts?
     
  25. egraphixstudios macrumors 6502

    egraphixstudios

    Joined:
    Dec 28, 2007
    #25
    ok so i decided to wipe the device again and tried from a fresh start- no restore of a previous backup. Re-setup the account from fresh then slowly started to work on exchange 2010 account.

    As for the exchange 2013 account- I had to reset the security permissions on my account in active directory back to defaults and voila it started working.
     

Share This Page