iOS 9.2 breaks iMessage

Discussion in 'iOS 9' started by Bhang, Dec 20, 2015.

  1. Bhang macrumors member

    Joined:
    Oct 10, 2011
    #1
    I have tried everything but even turning off send as SMS does nothing. No matter what I do I get charged for every text even when I have access to wifi. Anyone else having this issue? I'm on a pay as you go plan and I get and send a lot of texts. Its costing me quite a bit. Would love to know if there is a fix. I even took out the Sim card and as soon as I try to send an Imessage text it says, "No Sim Card" and won't send the message. :-(
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    try resetting network settings?
     
  3. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #3
    You do know that the person that you are trying to iMessage has to have an iDevice and be logged into iMessage, correct? BTW, 9.2 didn't break iMessage, or this forum would be flooded with posts/threads.
     
  4. Bhang thread starter macrumors member

    Joined:
    Oct 10, 2011
    #4
    Thanks, I will try resetting network connections.
    And, yes, I do know that both the receiving and sending phone need to be Iphones and using Imessage. You are also right that the forum would be flooded if it was broken. I'm just wondering why all of the sudden after updating it doesn't seem to work for me. Even if I turn off "Send as SMS" it still sends and receives SMS. It never did this before so something is amiss.
     
  5. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #5
    Also, both ends have to have a "solid" broadband connection for iMessage to work.
    Turning "send as SMS" doesn't prevent the message from being sent as SMS, it is supposed to prevent the message being sent as SMS, without first prompting the user for permission to do so.

    If resetting network connections, doesn't resolve the issue, I would log out and back in to iMessage. In fact, I would probably log out of iCloud, iMessage, and FaceTime, then log back in using that order.

    You don't have to actually send a message to test iMessage functionality. Open messages, select someone with an iDevice, type one letter, and look at the send button. If it is blue, that message will be sent as an iMessage, if it is green it is going as SMS.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Are people sending you iMessages (it comes up blue for them) and you are getting them that way? Or are they sending you SMS actually?
     
  7. Max(IT) Suspended

    Max(IT)

    Joined:
    Dec 8, 2009
    Location:
    Italy
  8. Bhang thread starter macrumors member

    Joined:
    Oct 10, 2011
    #8
    I tried resetting network and logging out of imessage. I don't use icloud so I can't log out of that. Its showing up green even though both sides are imessage enabled and using wifi. I'm also getting a message showing SMS charges after I make a phone call. Something is definitely up but I wonder if it may be something to do with my carrier since no one else seems to be experiencing this issue.
    Thank you all for your help and input.
     

Share This Page