iOS 9 bug that may drive you crazy

Discussion in 'iOS 9' started by rob.james.arias, Sep 18, 2015.

  1. rob.james.arias macrumors regular

    rob.james.arias

    Joined:
    Apr 20, 2015
    #1
    So I have found a bug in iOS 9 that I have been able to replicate on 3 different iPhones. It may have mentioned elsewhere but I have not seen anyone else talking about it. I will describe how to replicate it and why it does to the best of my ability. It may seem trivial to some however it is driving me crazy at the moment. I would downgrade to iOS 8.4 if my apple watch was not on 2.0 GM.

    When waking the phone the first touch on the home screen is not registered. In particular, the first swipe in any direction. If you swipe immediately after the first attempt it will register. If you unlock the phone and wait 2-3 seconds then the issue does not persist.

    It seems to be related passcode and finger id to unlock.

    TLDR; unlock your phone to the home screen, swipe immediately in any direction, the first swipe does not register.

    Anyone else? BTW I have only tested on the iPhone 6 and 6+, I cannot comment on other models.
     
  2. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #2
    For me, it registers but it stutters back to the 1st page as though I didn't complete the swipe, if that makes any sense. I know what you're talking about....very frustrating.
     
  3. tekchic macrumors 65816

    tekchic

    Joined:
    Apr 19, 2010
    Location:
    Phoenix, AZ
    #3
    Interesting. On mine it appears that I have to wait for the animation of the icons to "set" in the home screen before it registers the swipe. If I wait for the silly animation, the swipe registers. If I try to swipe immediately, it's ignored. Animation bug?
     
  4. rob.james.arias thread starter macrumors regular

    rob.james.arias

    Joined:
    Apr 20, 2015
    #4
    Interesting. That may be the reason.
     
  5. Ashin macrumors 6502a

    Ashin

    Joined:
    Jun 19, 2010
    #5
    Hasn't it always been like this? You always have to wait till the icons finish "flying in"
     
  6. rob.james.arias thread starter macrumors regular

    rob.james.arias

    Joined:
    Apr 20, 2015
    #6
    The issue for me happens even after the icons fly in. I have to wait a full 2-3 seconds after if I want touch to be recognized on the first attempt. I just tested it again.
     
  7. Ashin macrumors 6502a

    Ashin

    Joined:
    Jun 19, 2010
    #7
    No problem here - iPhone 5S

    Unlock with finger, waited, first touch is recognised.
    Unlock with finger, wait for the first moment the icons land, first touch is recognised.

    Did you update or clean install?
     
  8. AbeFrohman macrumors 6502

    AbeFrohman

    Joined:
    Mar 18, 2011
    #8
    Well it didn't drive me crazy until you pointed it out! I have reduce motion set to ON, so no "flying in" of icons, but it still doesn't register first swipe.
     
  9. mattyu007 macrumors member

    mattyu007

    Joined:
    Jan 29, 2010
    Location:
    Toronto, Canada
    #9
    I’m pretty sure it’s been like this since iOS 7, you have to wait for the animation (flying in or the fade if you have Reduce Motion on) to finish before it’ll respond to touches.
     
  10. Peepo macrumors 6502a

    Joined:
    Jun 18, 2009
    #10
    Never noticed this as an issue in normal use. I use touchid and by the time I lift my thumb off the button and move to the screen I never have an issue. But I always wait until the animation stops. Doesn't take 2-3 seconds.
     
  11. gordon1234 macrumors 6502a

    Joined:
    Jun 23, 2010
    #11
    As others have stated, you have to wait for the animation to complete, which while annoying, is not at all new. Pretty much the instant the icons stop moving, I can swipe in any direction with no problems at all…
     
  12. rob.james.arias thread starter macrumors regular

    rob.james.arias

    Joined:
    Apr 20, 2015
    #12
    Clean install.

    So your having the same issue. Sounds like some people don't have an issue. For me I have to wait several seconds after the icon fly in. Can you confirm the same for you?
     
  13. Act3 macrumors 65816

    Joined:
    Sep 26, 2014
    Location:
    USA
    #14
    I see this as well on the iPhone 6. However I also see it on my wife's iPhone 6 that is still running iOS 8.4.1.
     
  14. KUguardgrl13 macrumors 68020

    KUguardgrl13

    Joined:
    May 16, 2013
    Location:
    Kansas, USA
    #15
    Not a problem on my iPhone 5. I can swipe or click as soon as the animation finishes.
     
  15. thedru13 macrumors regular

    Joined:
    Sep 12, 2014
    #16
  16. iapplelove macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #17
    hmm op I have tried several times with my 6 plus to duplicate the issue however I cannot .
     
  17. jr866gooner macrumors 65816

    jr866gooner

    Joined:
    Aug 24, 2013
    #18
    For me it's, swipe to unlock is fine but it fails to register my first number on the passcode as if I'm too quick for it. It's ok if I swipe, leave it a second or so then type passcode..
     
  18. thedru13 macrumors regular

    Joined:
    Sep 12, 2014
    #19
    This!!!!!
     
  19. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #20
    Can't remember back that far, but, I've run into this on iOS 8, and without any real animations enabled (turned all the bells/whistles off in iOS 7(?)). So, yeah, been around before iOS 9. Always chalked it up to me along the lines of "holding it wrong" ("swiping it wrong"?).
     
  20. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #21
    I guess I haven't noticed this because everything I have is on 1 page haha.
     
  21. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #22
    The unresponsive touch I notice is on my Air 2. When I select an app from the app switcher I start scrolling in the app before it's ready so the app won't respond. The problem is I can do this without even trying.

    Not a really big issue but it's definitely a change from iOS 8.

    I made a quick video, if you turn the volume up you can hear how slowly I'm tapping (excuse the background noise my gf was blow drying her hair).

     
  22. docprego macrumors 65816

    Joined:
    Jun 12, 2007
    Location:
    Henderson, NV
    #23
    iPhone 6 Plus upgraded, not fresh install. Reduce motion is on, as is reduce transparency, both to battle the choppy multitasking interface animation which has helped. BUT I definitely still experience this bug. If I place my finger on the screen after unlocking my phone and maintain contact I can move my finger all around the screen indefinitely and no touches are recognized. However if I lift my finger the second touch always is. I can't understand why this would be by design, but also can't understand how a bug of this magnitude made it into the public release.
     
  23. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #24
    And that's exactly it. It was changed in iOS 7 when interactions where changed to not register while there's animation or fading happening. Been discussed in almost endless threads after more threads in iOS 7 forum, then iOS 8 forum, and now here. It's not good, but been this way for a few years now.
     
  24. rob.james.arias thread starter macrumors regular

    rob.james.arias

    Joined:
    Apr 20, 2015
    #25

    I disagree respectfully in this instance for my case in particular. Here is why, for me this issue is new to iOS 9. It was not present in any of the betas. It is apparent after the animations end, not durning which I understand was changed in iOS 7. My wife has an iPhone 6 that is not upgraded to iOS 9 and when doing a side by side comparison there is no "missed touch". I am very in tune with my devices and noticed this the very first time I unlocked my phone after the upgrade. Others may have had something similar in the past, I don't discount that however this was obviously apparent to me right away.

    There is also this, docprego has exactly the same issue. I think it is software related and like all bugs some people have it and some don't. Not sure why this happens but it does. For some of us the struggle is real ;-)
     

Share This Page