iPhone iOS 9 Podcast App Constantly Crashes While Updating Library

Discussion in 'iOS 9' started by karmakat, Sep 16, 2015.

  1. karmakat macrumors newbie

    karmakat

    Joined:
    Feb 10, 2004
    #1
    This appears to have been a problem during the beta, but I can't find a mention of it yet for the official iOS 9 release today so I thought I'd start us off…

    After the update, launching the Podcast app gets an "Updating Library" screen and then dies after about 10 seconds of the spinning gear.

    Note that I did have a HUGE library and there's probably an issue with memory. I had 30 gigs of podcast episodes comprising over 150 podcasts to which I'd subscribed.

    As a first attempt to fix I deleted every single podcast on the phone to try and clear out the library, but the badge still indicated that I had 9 unplayed podcasts and it still crashed again on launch while attempting to update the library.

    Resetting the iPhone did not fix.

    No clue where to go next for a fix and I will be calling Apple. I'll report back here if I find anything useful.
     
  2. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #2
    I have the same issue. Tried everything, still doesn't work.
     
  3. karmakat thread starter macrumors newbie

    karmakat

    Joined:
    Feb 10, 2004
    #3
    Follow-Up
    I received my new iPhone and had hoped that migrating to it would fix the problem. Silly me, of course. :) It just transferred the crashing on over. I eventually had to wipe the new phone and set it up as a new device in order to fix the library update crash issue. The good news is that my podcast subscriptions were saved in iCloud and the fresh copy of Podcasts pulled just about everything in. I did have to re-download all the episodes I wanted and lost my place on all the subscriptions, but that was better than I'd planned.

    The downside was that some of the episodes to older shows (some which no longer exist) that I'd saved were wiped on the phone and, although I had some of those synced to my computer, syncing back to the phone would have wiped the phone again as iTunes didn't recognize it as owned by me etc. and all that. If I'm willing to waste more time on it, I can find other ways to get those episodes onto the phone, (WALTR has been pretty useful in a sort of brute-force kind of way) but for now, it's good enough.
     

Share This Page