iOS 9 Restore from iCloud - No Photos

Discussion in 'iOS 9' started by AbSoluTc, Jul 30, 2015.

  1. AbSoluTc macrumors 68040

    AbSoluTc

    Joined:
    Sep 21, 2008
    #1
    So I had to get my phone replaced at Apple. Installed iOS 9 B4 and then restored from my iCloud backup. All is well except for my photos. It pulled in the total which is right, but it has only restored about 25 out of 3,850 of them. It doesn't appear to be doing anymore.

    Is there anyway to get it going again or do I have to wipe and restore again? Don't want to do that as it takes forever but I will if I must.

    Thanks!
     
  2. rzc16512 macrumors regular

    Joined:
    Jun 3, 2015
    #2
    If you use iCloud Photo Library that might be the problem as people have been reporting issues with iCloud on DownDetector and I am currently unable to view the full quality photos on my ios device. I just get an error stating the picture can't be downloaded
     
  3. AbSoluTc thread starter macrumors 68040

    AbSoluTc

    Joined:
    Sep 21, 2008
    #3
    I read about that. I don't use iCloud Photo Library as I think it's still glitchy. Always keep it off.

    When I lock my phone, it still says "restoring from iCloud backup" but nothing else is going. Photos have stopped. Not sure if I should turn it off and on.
     
  4. AbSoluTc thread starter macrumors 68040

    AbSoluTc

    Joined:
    Sep 21, 2008
    #4
    Anyone have any other ideas?

    I just wiped the phone and started again. Same issue. It downloads everything but stalls on the everything in my Photos app. Restarted the phone, nada. On the lock screen and in iCloud backup, it says it's restoring from iCloud. Yet it's not.
     
  5. benfica88 macrumors regular

    Joined:
    Nov 21, 2008
    #5
    I had the same issue every time as well. I had both phones and just used iMazing to clone.
    You can try and see if Anytrans would help you. I know it allows you to manage iCloud backups.
     
  6. AbSoluTc thread starter macrumors 68040

    AbSoluTc

    Joined:
    Sep 21, 2008
    #6
    I just did a restore again for the third time. Same thing. It never goes beyond the 127 photos out of 3,850. Really annoying as I also cannot backup while it's stuck in restore mode.

    I don't have the other phone, it was returned to Apple and wiped. I will look into those apps but my only backup is iCloud.

    Anyone have any other advice/options?
     
  7. iMacDragon macrumors 65816

    iMacDragon

    Joined:
    Oct 18, 2008
    Location:
    UK
    #7
    How long have you given it? As I understand it it can take a long while for photos to download.
     
  8. AbSoluTc thread starter macrumors 68040

    AbSoluTc

    Joined:
    Sep 21, 2008
    #8
    I gave it 7 hours on the second go. Nada. I am aware it can take a LOOOOONG time but it's usually within 3-4 hours. You can also see the progress of the download as each photo is added. It's not doing that. I just halts at 127 and goes no further.

    I am wiping my phone again and restoring the B4 download from the developers site and going to give it one more shot. If after that, I give up as I have tried everything. I also deleted some photos from my photo stream to see if that might possibly help or unclog something. It's a long shot but whatever.

    I have 3,974 pictures. What's interesting is, it knows that, sees my albums and has a count for what's in there. Just won't download the pictures.
     
  9. crashoverride77 macrumors 65816

    Joined:
    Jan 27, 2014
    #9
    Why do you think IPL is glitchy? I have been using it since the beta months ago and never had an issue. On the contrary IPL is pretty damn sweet. It saves you the hassle to sync stuff between devices, it saves you space and its backed up on apples servers. If you had a bad experience with it maybe give it another go. Also running an iOS beta should not give you an indication of how a services works.
     
  10. iMacDragon macrumors 65816

    iMacDragon

    Joined:
    Oct 18, 2008
    Location:
    UK
    #10
    Fair enough, I'd think 7 hours was long enough indeed. 127 does sound like the kind of number that could be a bug of some sort.. or just a coincidence.. I presume b5 will come out next week, probably worth trying again on that I guess.. But, this is after all a beta.. I wouldn't rely on icloud during beta period really :/, it's already been known to be pretty buggy with backups since b1, with storage space vanishing etc.
     

Share This Page